0

I've got a very strange problem with this website. The background slides appear when your English flag but when its switched to The Spanish flag or Other flag the backgrounds don't appear. Link to website

Code thats generating the flags

<?php
                // SELECTOR DE IDIOMAS
                //
                function language_selector_flags(){
                    $languages = icl_get_languages('skip_missing=0&orderby=code');
                    if(!empty($languages)){
                        foreach($languages as $l){
                            if(!$l['active']) echo '<a href="'.$l['url'].'" onClick="_gaq.push([\'_link\', \'' . $l['url'] . '\']); return false;">';
                            echo '<img src="'.$l['country_flag_url'].'" height="30" alt="'.$l['language_code'].'" width="47" />';
                            if(!$l['active']) echo '</a>';
                        }
                    }
                }
                //if ( is_page(array( 'pagename', 'pagename', 'pagename','pagename'))) {
                    language_selector_flags();
                //}
                ?>

The backgrounds are generated by a plugin called wp_supersized. I'm slightly confused as to why it doesn't just work unless some html is been changed when the language flags are activated.

Thanks for any help.

2
  • however that plugin determines what page to run on, it's not being triggered on your other language pages. there's no trace of the script that generates the slideshow on your alternate language pages.
    – Milo
    Nov 29 '13 at 16:44
  • May sound like a silly question - but can you see what part of the code activates this. I've set the plugin to display on all pages.
    – dannyw24
    Nov 29 '13 at 16:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.