0

I have seen many similar posts about similar problems, but they all seem to say delete the redirect plugin but the only plugin I have is google analytics. The site was working ok, but suddenly redirects to the main site if you enter or click a link to http://www.mysite.co.uk/wordpress it redirects to http://www.mysite.co.uk i can find no way to change this even with the .htaccess file any ideas?

  • 1
    Things don't just suddenly stop working. Something happened. You need to work out what. Server change or update? Server crash? Software install or update-- theme, plugin, WordPress itself, PHP, something? Check your logs. Ask your host. Post debugging information And... 1) post all of the relevant code here and not as a comment to an answer. 2) Use real URLs. Fake ones are utterly useless. – s_ha_dum Nov 26 '13 at 14:47
0

Check your general settings page, if the correct URL is filled in there.

Check if your Cpanel has no site redirect enabled.

And do post your htaccess here please.

|improve this answer|||||
  • general settings are set to mysite.co.uk/wordpress on both lines – user43167 Nov 26 '13 at 14:32
  • .htaccess has this part for wordpress # BEGIN WordPress <IfModule mod_rewrite.c> RewriteEngine On RewriteBase /wordpress/ RewriteRule ^index\.php$ - [L] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /wordpress/index.php [L] </IfModule> # END WordPress – user43167 Nov 26 '13 at 14:33
  • Is that htaccess located in your domain mysite.co.uk or in the folder wordpress? – gelleby Nov 26 '13 at 14:35
  • the wordpress section of the .htaccess is the same in both the main folder and the wordpress folder – user43167 Nov 26 '13 at 14:36
  • Do you have a Admin Panel on that domain? Is there a redirect set in that panel? – gelleby Nov 26 '13 at 14:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.