I'm deploying a multi-site network, using subfolders. I've found on the main site the permalinks for news posts can only be placed like so:


I understand that this prefix is needed to lessen the risk of conflict between the main site and sub-sites. Unfortunately this is a serious website, where the word 'blog' isn't really appropriate. Something like /pressreleases would be much more appropriate, and still avoid conflicts.

I tried various of the 'tricks' people mention, such as editing the permalink structure from the network admin settings. I also tried using rewrite rules (both Apache and the Redirection plugin) without much luck. WordPress needs to believe the posts are at the location in the address bar, so rewriting results in a 404. I could redirect them back to /blog, but that still has the same problem.

How can I change the permalinks?

1 Answer 1


Let see if I remember this correctly.

  1. Go to http://yoursite.com/wp-admin/options.php
  2. Find permalink_structure. By default, the value should be /blog/%year%/%monthnum%/%postname%/
  3. Change the value manually to whatever value you like. e.g /pressreleases/%year%/%monthnum%/%postname%/ or just /%year%/%monthnum%/%postname%/. Then Save Changes.
  4. Now visit http://yoursite.com/wp-admin/options-permalink.php and DON'T click Save Changes. It should flush the rules. If you click Save Changes it will revert back to the default.


  • Is there some way of making this change in code, so the client doesn't accidentally alter it? Apr 27, 2011 at 12:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.