0

I recently upgraded my dedicated server to Apache 2.4.6, MySQL 5.5.32, and PHP 5.4.21. Now on my website I get this error:

Warning: preg_replace(): Compilation failed: unknown option bit(s) set at offset -1 in /home/champion/public_html/wp-includes/shortcodes.php on line 295

Here is the code from shortcodes.php on line 295:

$text = preg_replace("/[\x{00a0}\x{200b}]+/u", " ", $text);

Is the preg_replace function not compatible with the new PHP 5.4.21?

  • Please clarify how this question is specific to WordPress. – Chip Bennett Nov 14 '13 at 14:02
  • It's a WordPress website. – Daniel Harris Nov 14 '13 at 14:03
  • 1
    That doesn't make the question specific to WordPress. Per the WPSE FAQ, questions not specific to WordPress are off-topic, even if they happen in the context of WordPress. – Chip Bennett Nov 14 '13 at 14:05
  • OK, here's the link to the new thread link – Daniel Harris Nov 14 '13 at 14:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.