0

I'm using WordPress 3.5 with child-theme of Twenty Eleven 1.5. Suddenly I'm getting following Warning,

Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'cp_admin_init' was given in /home/templ/public_html/wp-includes/plugin.php on line 406

Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, '_canonical_charset' was given in /home/templ/public_html/wp-includes/plugin.php on line 173

I'm using following plugins:

  • download-manager 2.3.9
  • wordpress-seo 1.4.7
  • wp-pagenavi 2.83

Some more points:

1) If I'm giving mysite.com it's giving above 2 line warning. If I give www.mysite.com, the following line also include,

Warning: Cannot modify header information - headers already sent by (output started at /home/templ/public_html/wp-includes/plugin.php:406) in /home/templ/public_html/wp-includes/pluggable.php on line 876

2) If I give mysite.com/wp-admin/ or www.mysite.com/wp-admin/, It's giving 1st warning and 3rd warning.

3) If I goto www.mysite.com/wp-login.php, It's giving following 5 warning.

Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'cp_admin_init' was given in /home/templ/public_html/wp-includes/plugin.php on line 406

Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, '_canonical_charset' was given in /home/templ/public_html/wp-includes/plugin.php on line 173

Warning: Cannot modify header information - headers already sent by (output started at /home/templ/public_html/wp-includes/plugin.php:406) in /home/templ/public_html/wp-login.php on line 368

Warning: Cannot modify header information - headers already sent by (output started at /home/templ/public_html/wp-includes/plugin.php:406) in /home/templ/public_html/wp-login.php on line 380

Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'wp_authenticate_spam_check' was given in /home/templ/public_html/wp-includes/plugin.php on line 173

4) If I give correct username and password, it's not going to login. giving following problem,

ERROR: Invalid username or incorrect password.
ERROR: Cookies are blocked or not supported by your browser. You must enable cookies to use WordPress.

I'm trying to find solution. I can't. Can any-one help me?

  • While I don't want to frighten you, things rarely just "suddenly" get weird. Chances are that someone has done something whether that be you, your host, or (worst case) a hacker. It could also be corrupt files from a failed update or hardware failure. The first thing you should do is contact your host, and seriously consider a complete, thorough update of the site. – s_ha_dum Nov 5 '13 at 14:39
  • How I can update without login? – KarSho Nov 5 '13 at 15:06
  • The only way you should be updating, in my opinion, (s)FTP. – s_ha_dum Nov 5 '13 at 15:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.