0

I'm having a big issue with /wp-admin login page on GoDaddy Hosting Account (Windows).

I can't log in if I visit the following url. I get re-directed to the login page again.

  • domain.com/wp-admin

I can log in if I use the following urls.

  • domain.com/wp-admin/ (with the forward slash on the end)
  • domain.com/admin
  • domain.com/login

I pointed the domain I want to use to the installation of my wordpress, which is under a sub-directory of the root.

  • Disabled permalinks (removed web.config which is I guess .htaccess for windows)
  • Disabled plug-ins
  • Verified Site URL in the database (It doesn't contain an extra forward slash)

When I log into wp-admin I am redirected to.

domain.com/wp-login.php?redirect_to=http%3A%2F%2Fdomain.com%2F sub-directory %2Fwp-admin%2F&reauth=1

The url is incorrect and the sub-directory should not be there.

Visiting wp-admin/ with the forward slash directs me to the correct url.

domain.com/wp-login.php?redirect_to=http%3A%2F%2Fdomain.com%2Fwp-admin%2F&reauth=1

GoDaddy Support does not see an issue here.

  • 1
    Oh, gee, why Windows? – brasofilo Nov 4 '13 at 18:22
  • It's not my hosting account, I suggested strongly against it. :/ – hyperdrive Nov 4 '13 at 18:24
1

I solved this, try the following:

  • Go to permalinks settings
  • Change the setting selected
  • Save
  • Come back to permalinks settings
  • Restore the setting selected
  • Save

Good luck!

0

This drove me pretty tense the whole morning finally I found out there was a security plug in that prevented me from logging in unless I was logged into my cpanel on the back end. Hope that helps.

The exact name of the plug is was WPS Hide Login that one of the developers had installed for security. I went into the back end cpanel on go daddy and it had a different link to be able to access the wp-admin section and make changes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.