0

First off, I've customised my WordPress folder structure a bit:

enter image description here

wordpress/ contains all the files a fresh WordPress install does (wp-admin, wp-includes, etc)

The problem I'm facing is that a couple of third-party services can't seem to "interact" with WordPress this way (for example: editorially.com, ifttt.com). They either fail to authorise or give the following error:

Someone may be trying to trick you into giving them access to your site. 
Or it could be you just encountered a bug :). Either way, please close this window.

I've tried symlinking wp-admin.php and wp-admin/ to my web root but that doesn't fix it. Any advice on how this could be solved or how I could further troubleshoot this?

----- EDIT ----

My wp-config was modified as below:

define('WP_SITEURL', 'http://' . $_SERVER['SERVER_NAME'] . '/wordpress');
define('WP_HOME',    'http://' . $_SERVER['SERVER_NAME']);

define('WP_CONTENT_DIR', $_SERVER['DOCUMENT_ROOT'] . '/wp-content');
define('WP_CONTENT_URL', 'http://' . $_SERVER['SERVER_NAME'] . '/wp-content');

And my index.php file looks like this:

define('WP_USE_THEMES', true);

/** Loads the WordPress Environment and Template */
require('./wordpress/wp-blog-header.php');

Both of these services (ifttt and editorially) has the option to create new posts in your WordPress install, I've tested both with a standard WordPress install and there they work flawlessly.

My apache access log show the following error:

54.235.21.109 - - [02/Nov/2013:22:00:02 +0100] "POST /xmlrpc.php HTTP/1.1" 404 15092

Symlinking that file to the root of my site solves the problem with ifttt.com, but not with editorially, which is still giving me the "Someone may be trying to trick you into giving them access to your site" error as mentioned above. Editorially asks you to log in with your wordpress.com account and required the WordPress Jetpack plugin to be installed. That is the case here and it is linked to my wordpress.com account.

  • How did you pull off that customization? – s_ha_dum Nov 2 '13 at 20:15
  • Change some paths in wp-config and add "require('./wordpress/wp-blog-header.php');" to index.php, has been working perfectly for months, until this one came along... – Jan Henckens Nov 2 '13 at 20:18
  • So, add exactly what you did (code and all) as an edit to the question. Depending on what you did, this may not be a WordPress issue. That is what I am trying to get at. Have you checked the server logs to see exactly what the URLs are that those services are trying to access? And what is the nature of the "access"? Are plugins involved? – s_ha_dum Nov 2 '13 at 20:29
  • Added code excerpts of what I changed and some further troubleshooting. – Jan Henckens Nov 2 '13 at 21:12
  • Maybe you can adjust your rewrite rules? Here is my attempt to make a similar directory structure (WordPress-Skeleton) work for a subdirectory multisite install with NginX rewrite rules. This will give me access to for example example.com/site2/xmlrpc.php. I've not tested the above services, but it's just an idea ;-) – birgire Nov 3 '13 at 3:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.