I am trying to update wordpress from 3.6 to 3.7 using the updater in the admin backend. This is something that has always worked fine in the past on the server my site is on but for some reason when I click the "Update Now" button (which should run the script in wp-admin/update-core.php the page hangs for a minute or two before going to a blank admin page (i.e. the wp-admin menu bars and header bar are there but there is no content in the body of the page).

Any idea what's causing this? I've tried deactivating some plugins but woocommerce must be kept on for as long as possible in case of an order going through - in any case I doubt it would cause this failure.

Edit: as a site note, my site runs on a VPS running Ubuntu 12.10 on Nginx with php 5.4.6. I also have a few other wordpress sites on the same server on different vhost. They are much simpler and use completely different themes and only a couple of simple plugins. The update still fails on them in the same way suggesting a server issue rather than an issue with themes or plugins.

As mentioned I will check logs but at work currently where ftp and ssh ports are blocked which makes it tricky.

Edit 2: Having reviewed the log an entry is recorded when I run the upload and it fails:

2013/10/29 23:20:48 [error] 9384#0: *5318248 upstream timed out (110: Connection timed out) while reading upstream, client:, server: www.sergedenimes.com, request: "POST /wp-admin/update-core.php?action=do-core-upgrade HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "sergedenimes.com", referrer: "http://sergedenimes.com/wp-admin/update-core.php"

I have tried restarting both php-fpm and Nginx to no avail. It looks like it could be a server config problem but the rest of the site works flawlessly (including updating plugins). The issue is not specific to just this site. On my VPS I have 3 other WordPress sites running on separate vhosts that all share the same update problem.

Any idea what the cause could be and how to solve?

  • 2
    Please do proper debugging, including deactivating all Plugins and switching to a core-bundled Theme to ensure that the issue is with core, rather than a Theme or Plugin. – Chip Bennett Oct 28 '13 at 13:28
  • This isn't really an option as the site is in constant use from visitors and is processing orders. I few seconds maintainance mode is fine but my client cannot accept switching themes and turning off vital plugins. Is there no other way to track down the issue? – harryg Oct 28 '13 at 13:31
  • 1
    "This isn't really an option..." - then there really isn't anything we can do to help you. If you suspect that WooCommerce is contributing to the problem, then you should contact WooSupport. – Chip Bennett Oct 28 '13 at 13:42
  • 1
    "Is there no other way to track down the issue?" -- run a copy of the site a local server and test that. But, logging errors to a file should not cause your client much pain. – s_ha_dum Oct 28 '13 at 14:33
  • 1
    @harryg you should probably set up a dev environment anyway, what would happen if there was an issue after updating to 3.7? You'd be talking about extensive downtime to troubleshoot. – Andrew Bartel Oct 28 '13 at 18:40

I'm also having the same problem. Plugin Updates work fine, but Wordpress 3.7 (or the new 3.7.1 update) fail. Manual updating via copying over the wordpress core files worked to update to 3.7, but the 3.7.1 update fails again.

I then changed nginx.conf and added in the http part (read it somewhere else - it's a solution to get the update through, but no solution on to why it's soooo slow):

fastcgi_read_timeout 600s;    

this worked. However Updates still take forever. Sometimes also when me or someone else wants to write a comment, it takes up to 5 seconds to register the comment. Everything else for me is blazing fast (the server is completly overpowered, just serving some big files (about 5TB month) and two websites with about 300.000 visitors/month (i7, 8GB RAM, 200Mbit up/down).

  • Interesting. I will do some more tests tonight. Also will try the php-fpm slow log which should give info on slow-running scripts. My server should also easily handle things like WP updates in seconds. Comments work fine for me. – harryg Oct 30 '13 at 17:30
  • Turns out it was some sort of server issue. I increased the execution timeout on my vhost's nginx config file and it fixed it. The strange thing is is that when it worked the update completed almost instantly. It didn't take any where near even the original timeout limit. – harryg Nov 4 '13 at 16:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.