0

Am developing a WordPress site. My site footer having a link to navigate RSS Feed URL. This URL is generated using <?php bloginfo('rss2_url'); ?> and it correctly generating the URL like mysite.com/?feed=rss2 but this link is not working from home page. Showing page not found when i try to access it from home page. But When i try to access it from category page the link is working. Please help me to solve this issue.

Thank you. Hariprasad

Update

Am not using default category or post of wordpress. Only using custom post type and custom taxonomies.

  • does it work on the default theme minus plugins? – birgire Oct 19 '13 at 13:04
0

Hm... It's kind a strange. Maybe it is related to your permalink stucture. I know that WP render RSS feed for any page. Did you try to display RSS feed manualy? Will that solve your problem?

Site feed should be on /feed/

Also, it can be found on /category/your-category/feed/

as well as on /tag/your-tag/feed/

Just put /feed/ in place where you need and that should solve your problem.

  • Thanks for your reply. Am not using default category or post of wordpress. Only using custom post type and custom taxonomies. – hariprasad Oct 19 '13 at 13:24
  • 1
    How did you register those post types? Did you place the code inside functions.php or you use some plugin? If you solve it inside functions.php make sure to set arguments: 'has_archive' => true, 'feeds' => true, I hope that this will help. – pendjer Oct 19 '13 at 16:22
0

If your WP installation not affected by any rewrite rules tranformer (that manipulate rewrite rules list) i can imagine only one case when its possible... you don't have post (with post type 'post'). Hoever first assumption you can check with debug bar plugin... take a look what's in WP_Query tab inside...

  • I don't have any posts with posttype "post". Completly using custom post type – hariprasad Oct 19 '13 at 13:27
  • 1
    Ok. you basicly just got an answer on question - why it doesn't work. WP will give you 404 on any page that in result doesn't contain any post inside (any post type). What i think you need to do is change default rewrite rule for feed to your last posts. Can you give me an idea what post type you want to show in feed ? – Butuzov Oct 19 '13 at 13:39
0

Solved it

I think the custom post types does not display in feed by default.

It worked when i add following code in function.php

//enabling feeds for custom post types..
function myfeed_request($qv) {
if (isset($qv['feed']) && !isset($qv['post_type']))
$qv['post_type'] = array('news', 'results', 'events', 'video-gallery');
return $qv;
}
add_filter('request', 'myfeed_request');

Thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.