I have my wordpress install under svn. I was on version 2.9.2. These were the steps I took:

  • saved a copy of my current wordpress directory
  • cd into my top level wordpress directory
  • svn up (just to make sure that I have the latest of 2.9)
  • svn sw http://core.svn.wordpress.org/tags/3.0.1/ . (upgrade)
  • run wp-admin/upgrade.php
  • got this error "Fatal error: Call to undefined function is_multisite() in (my install directory)/wordpress/wp-includes/wp-db.php on line 505"

I looked around and some people think it's a memory issue with PHP. So I tried the Memory Bump plugin and that didn't work.

Any ideas?

Update: Found this post. Downloaded the latest 3.0 tar and overwrote my wp-settings.php with the one in the download.

Get different errors now. "Fatal error: Cannot redeclare wp_load_image() (previously declared in /myinstalldir/wordpress/wp-includes/media.php:241) in /myinstalldir/wordpress/wp-admin/includes/image.php on line 168"

When I perform and svn status I see lots of 'S' flags (switched). Do I have to be concerned with that? wp-settings.php has that flag.

Update: Here's the output of the above svn sw from the root Wordpress directory.

Update: Output of svn st here. (Migrated the long listings to pastebin)

Update: Output of svn info

Path: .
URL: http://core.svn.wordpress.org/tags/3.0.1
Repository Root: http://core.svn.wordpress.org
Repository UUID: 1a063a9b-81f0-0310-95a4-ce76da25c4cd
Revision: 15559
Node Kind: directory
Schedule: normal
Last Changed Author: ryan
Last Changed Rev: 13165
Last Changed Date: 2010-02-15 09:38:59 -0800 (Mon, 15 Feb 2010)
  • 2
    Instead of updating your SVN working copy, have you tried the upgrade link from othe wp-admin section directly when logged in? It has worked without any problem for me on two WP installations already
    – Marek
    Sep 1, 2010 at 12:35
  • I don't see any of the "S" flags you mentioned. Given a clean svn sw between revisions, svn st should be almost empty except for any themes and plugins you've added. Your paste looks like a checkout that has had an upgrade to WordPress 3 applied manually, outside the scope of Subversion. What's the output of svn info on the WordPress directory? Betting it says tag 2.9.2. Sep 2, 2010 at 10:50
  • Also "U" is not a flag shown during status, it's an update flag. And status wouldn't attempt to delete a directory. So that doesn't seem to be the output of svn st. Sep 2, 2010 at 10:54
  • Just updated with all the info that Adam was asking about. Hope this helps.
    – milesmeow
    Sep 3, 2010 at 2:39
  • @Marek : I actually just decided to try using the upgrade link from the admin section and it worked without a hitch! Even though now my code base is probably very different (in SVN's eyes) from the repo, I think I'm happy for now. If I have more time to spend, I may try to do a clean install from SVN for v3.0.
    – milesmeow
    Sep 11, 2010 at 4:51

2 Answers 2


I also used SVN before to update my wordpress installation. Up the working copied will get messed up very quickly with all the manual updates or files created by plugins.

I would always recommend to use the update functionality of wordpress if you only want to step from one tagged version to another one.

Although, I also use SVN for a local copy of wordpress to be able to quickly test my plugins in some old version real quick. I use Eclipse to switch from one to another tag and until now it worked out. But you'll never know.

UPDATE: I just tried to switch a clean checkout of 2.9.2 to 3.0.1 which looks like it is working, but I can only see the backend and not the frontend of the default single blog.

UPDATE: What even the debug mode doesn't tell me: As the default pre WP 3.0 theme is no longer available I just have to switch to the new "2010" theme. Now everything is working.

So switching does work, but as I said before, your working copy usually get's messed up with a lot of files that might cause some problems updating your WP copy with SVN switch.

  • I used the 'upgrade' link in the wp-admin section and it worked. The error is still a mystery to me, but I'll leave that to another time...or I'll just let it be.
    – milesmeow
    Sep 11, 2010 at 4:52

Sounds like you ran svn sw in a subdirectory, rather than the top-level WordPress directory. We may be able to help you recover, if you can't just checkout a clean copy and move over your plugins and themes. The full output of svn st would be helpful, as well as svn info for any directory that may have been switched independent of its parent.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.