5

I open a page and make an edit and the update button becomes grayed out. I have to copy all page content, refresh the page and paste it back in the page, only then does the update button become clickable. It does update the page so there is no issue with that.

Only when making the initial edit is in not clickable.

Update: I was able to recreate the issue, but not faithfully. It seems to occur when the page is trying to auto save. It would begin to autosave and then hang.

I don't even know where to begin with this one. Has anyone encountered something similar?

7
  • 3
    check error console for javascript errors
    – Milo
    Commented Oct 9, 2013 at 21:20
  • In most of the cases it's only for a few moments, because of the autosave. But if it stays for long, then it's a problem. Commented Oct 10, 2013 at 3:56
  • @Milo I enabled the error log and then recreated the issue. Only PHP error or warnings were logged, noting in the way of Javascript. The problem has been going on for over a week now.
    – MagRat
    Commented Oct 10, 2013 at 15:03
  • I meant your browser's javascript error console.
    – Milo
    Commented Oct 10, 2013 at 15:04
  • Only showing one Warning related to superfish, used in the main site navigation. Should have no effect on the admin area.
    – MagRat
    Commented Oct 10, 2013 at 15:59

6 Answers 6

8

It appears to be a bug, but one that can be hacked around each time it happens with about 2 seconds of work. This wordpress forum thread:

If you're using Chrome, right-click on the greyed-out "Update" button and select "Inspect Element". You will see something to the likes of:

<input name="save" type="submit" class="button button-primary button-large disabled" id="publish" accesskey="p" value="Update">

Just delete the word disabled and the update button will become clickable again. Click it and it should update.

Saved me reloading and losing work.

See also this less resolved thread.

5
  • This question was asked in 2013. A lot of bug has been fixed now in WordPress. The thread you've posted also one year old. I do not think someone will be using this old version.
    – Sumit
    Commented Mar 24, 2016 at 5:20
  • 2
    I still have this bug, and this fix still works. I am running WordPress 4.3.3 on Chrome 47.0.2526.106, OSX 10.11.2. Commented Mar 24, 2016 at 13:03
  • 3
    I hacked around w/this fix but it wasn't magically working for me - still bugs out and prevents saving sometimes. Insane that this is STILL an issue as of 2017/03/23. Commented Mar 23, 2017 at 17:28
  • 1
    For posterity: I still have to hack around this Wordpress bug in the year 2020. I look forward to sharing this tip with my grandkids. Commented Feb 12, 2020 at 21:35
  • 1
    2021 and I'm running into this. Commented Oct 29, 2021 at 13:30
2

Once I realized it was an issue related to the Page/Post autosave, and not something to do with pasting the data from a text editor, I disabled all plugins to determine if that would be the cause. Disabling the plugins did not seem to have an effect.

No errors were reported in the browser error console.

I manually updated the Wordpress installation and this seems to have fixed the issue. Unfortunatley I do not understand why, none of the files replaced were ever edited by me.

2

I have the same issue. I inspected JavaScript and deleted aria-disabled="true" . The button was activated but still I couldn't save the page.

Luckily, I figured how to work around the issue and could save the page. First, I "saved it as draft". Then, went to "Pages" on Dashboard. I could convert the page to "Published" via the "Quick Edit" link. If anybody still cannot save the page, try it.

0

I registered a function in the save_post hook via

add_action('save_post', 'my_function', 10, 3);

In the function itself I did nothing, except logging for testing reasons, and the button still became disabled, once the autosave (and my function was triggered).

My function was also called peridodically ~20-30s according to the logs.

I deregisterd my function and the button worked flawlessly again.

It turned out, the logging to error_log/syslog itself was the problem. When I disabled my custom log function, my code and the registered function worked, and the button never became disabled again.

0

This problem is often due to a sucuri firewall perceiving your actions as malicious. If you have a sucuri firewall either directly or through some other provider, you need to whitelist your IP address and the problem will end.

0
0

Regarding the grayed out Update button, it is often the result of a sucuri firewall viewing your changes as malicious and my problem was resolved once I clicked on a URL supplied by sucuri while I was logged into my site which whitelisted my IP address so that the grayed out Update button would no longer happen. I suggest you contact sucuri or the vendor that uses sucuri to provide your firewall and ask to get your IP address whitelisted.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.