3
  1. On page --> Screen Options --> check Discussion --> Discussion --> Allow commets --> I have checked on discussion options.

  2. Settings --> Discussion --> I have checked on Allow people to post comments on new articles.

  3. I also have this code in my theme: <?php comments_template(); ?>

But the comment form is still not visible. What else do I have to do?

1
  • Stating the obvious, are you checking the right template? Sep 30, 2013 at 7:16

1 Answer 1

0

Go to the page.php template of your theme and check if <?php comments_template(); ?> is added there. If it isn't, then you need to add this line below your page content rendering section.

1
  • Yes, i have already add <?php comments_template(); ?> this code in page.php. but, still not enable comments option. Sep 30, 2013 at 9:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.