0

I got a problem trying to access the landing page typing domain.com instead www.domain.com If I type domain.com/rus the WP goes to domain.com/rus/wp-admin/install.php

but if I type www.domain.com/rus the landing page is loaded correctly if I type any address of known pages or post without the www the pages and post are loaded correctly, the main problem is the home page.

Settings:
reading : last post - taken from index.php
WP URL: http://www.domain.es/rus
Site URL: http://www.domain.es/rus

I have other site with same information http://www.domain.es/eng and this is working perfectly, now I´m planing to have a site in rusian :) but I got this error and I don´t want to transfer 400M of images again.

NOTES:
There aren´t blank spaces in wp-config.php ( i´ve solved this issues since 4 years ago) the .htaccess shows this code same as site eng (obviusly its own /eng and /rus folder) RewriteBase /rus/
RewriteRule . /rus/index.php [L]

0

Adding this lines to .htacces solved the redirect problem to wp-admin/install.php if typed the domain.com without the www even if the WP was completely installed and settings configured properly.
RewriteCond %{HTTP_HOST} ^www.domain.com/rus [NC]
RewriteRule ^$ /index.php [NC,L]

Now I can continue with rusian translation.

The main problem was a defective plugin, which was blocking the Adminn panel and routines that checks the config file; the error on the plugin was a wrong coded lines with non UTF-8 Format.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.