1

My wordpress loads whole jQuery UI library

<script type='text/javascript' src='http://example.com/wp-includes/js/jquery/ui/jquery.ui.core.min.js?ver=1.9.2'></script>
<script type='text/javascript' src='http://example.com/wp-includes/js/jquery/ui/jquery.ui.widget.min.js?ver=1.9.2'></script>
<script type='text/javascript' src='http://example.com/wp-includes/js/jquery/ui/jquery.ui.position.min.js?ver=1.9.2'></script>
<script type='text/javascript' src='http://example.com/wp-includes/js/jquery/ui/jquery.ui.mouse.min.js?ver=1.9.2'></script>
<script type='text/javascript' src='http://example.com/wp-includes/js/jquery/ui/jquery.ui.sortable.min.js?ver=1.9.2'></script>
<script type='text/javascript' src='http://example.com/wp-includes/js/jquery/ui/jquery.ui.datepicker.min.js?ver=1.9.2'></script>
<script type='text/javascript' src='http://example.com/wp-includes/js/jquery/ui/jquery.ui.menu.min.js?ver=1.9.2'></script>
<script type='text/javascript' src='http://example.com/wp-includes/js/jquery/ui/jquery.ui.autocomplete.min.js?ver=1.9.2'></script>
<script type='text/javascript' src='http://example.com/wp-includes/js/jquery/ui/jquery.ui.resizable.min.js?ver=1.9.2'></script>
<script type='text/javascript' src='http://example.com/wp-includes/js/jquery/ui/jquery.ui.draggable.min.js?ver=1.9.2'></script>
<script type='text/javascript' src='http://example.com/wp-includes/js/jquery/ui/jquery.ui.button.min.js?ver=1.9.2'></script>
<script type='text/javascript' src='http://example.com/wp-includes/js/jquery/ui/jquery.ui.dialog.min.js?ver=1.9.2'></script>

Is this normal? I didn't noticed the same behavior earlier.

  • 1
    I think it is not normal and I think that that files are loaded by a plugin. Have you tried to deactivate all the installed plugins to check if this behavior stops? – cybmeta Sep 16 '13 at 11:28
1

jQuery-UI is included in every default WP installation.
Whether it is loaded depends on your theme and/or plugin(s).

Three Options:

  • live with it
  • disable plugins one by one (and switch theme), figure out which is responsible and whether that's needed
  • manually deregister it (something, i.e. a plugin, will probably break)
0

Are you using "Events-Manager" plugin? There is an option to disable loading of unnecessary scripts. I found this to be the cause of all the extraordinary jquery.ui files.

You can change the loading here: visit the backend of your wordpress install > Events > Settings > General Tab > Performance Optimization THEN Limit JS file loading? Change this to YES

Limit loading of our CSS files? Change this to YES also.

Hit [ Save Changes (All) ] And you should be set

  • if this helps, please upvote my answer – Acts7Seven Nov 18 '13 at 18:17
  • Why do you think the OP is using this particular plugin? – s_ha_dum Nov 18 '13 at 18:40
  • Because I leaved a comment in answer? :) – CBeTJlu4ok Nov 18 '13 at 20:25
0

I had the same issue, My website used to load over 20 jquery ui scripts. I fixed it by disabling the plugin : Powie's Page Cloud Widget

If anyone has this issue, just disable all plugins and enable one by one. Because only plugins are responsible for this problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.