0

I've this WP installation that I'm currently modifying. And the craziest thing is that the HTML comments are not displayed anywhere in the source. That is if you right click on the page and "View Source". However if you are to open the page with a tool like this -> http://www.iwebtool.com/code_viewer?domain=w3lol.com you can clearly see that the comments are there. The website url is http://w3lol.com

The sad part is that there is no info anywhere on the matter and as a bonus I've no idea on how to determine if this is caused by the code itself, the Apache, WordPress or whatever...

(By the way, I've 5 other sites on this server, 4 of which are running WordPress and none of them has this problem. I'm also running an offline version of w3lol that does't show the problem either.)

Have anyone had an error like this? And do you have any suggestions on how to fix it?

9
  • I see the HTML comments in source of that URL just fine, the first of them is not particularly polite. :)
    – Rarst
    Commented Sep 12, 2013 at 20:49
  • I see a number of comments as well but also quite a few empty comments-- comments with nothing but spaces and probably a line break in them. Are those what you are talking about?
    – s_ha_dum
    Commented Sep 12, 2013 at 20:56
  • Do you have debugging information?
    – s_ha_dum
    Commented Sep 12, 2013 at 20:57
  • First of, I apologize for the first comment, I got a bit frustrated there :D The empty comments are fix for the inline-block element spacing, this is what was kind of important to me, because without it the page is all messed up. Anyway, I did test the website through Pingdom's tools and for my surprise it looked fine there, but I had my friend check it from all across town and she had the same error. Could this be in some way related to my ISP? Here's what I'm seeing i.imgur.com/YaZYN8n.png (PS. I tried debugging, but with no result). Commented Sep 12, 2013 at 21:23
  • 1
    That looks like Chrome? I checked in Chrome on Windows 7-- the markup does not look like what you see. That markup looks like it has been "cleaned". My guess is that it is something on your end. Does you ISP offer some "increase your load speed" service? Stripping what should be disposable data like comments is one good way to do that, which begs the question of "why are you using what should be disposable data in a way that forces the site layout to be dependent upon it?"
    – s_ha_dum
    Commented Sep 12, 2013 at 21:37

1 Answer 1

1

It seems that my ISP's DNS was not refreshing and was caching some stuff. While waiting for them to fix it as a temporary solution I changed my DNS to Google's public DNS as shown on this page developers.google.com/speed/public-dns/docs/using and everything seems fine.

1
  • Thank you for telling us how you resolved this. Please accept your answer to close the question. Commented Sep 15, 2013 at 6:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.