0

I'm using the WP UI plugin, and have a page set up with spoiler shortcodes so that you can "click to show" and "click to hide". Here's a link to the page in question: http://goinspire.com/faq/

My problem is this: I want to include a hyperlink within the text of one of the spoilers (which you only see after you "click to show"). When I inserted the html at wordpress "Edit Page", it displayed the actual html, instead of showing as a link.

Here's my spoiler:
[wpspoiler name="Do I need to buy travel insurance?" style="ui-lightness"]GoInspire highly recommends buying travel insurance for non-refundable tickets and land costs. Speak to our agent at 845-425-8255 ext. 209 for more info, or click <a href="https://www.mhross.com/index.php/consumer/index/goin0028" target="_blank">here</a> to read about our plans.[/wpspoiler]

Is there a way past this?

8
  • don't see any problem on the given url..
    – Sisir
    Sep 11, 2013 at 15:32
  • Can you look under this spoiler: Do I need to buy travel insurance?
    – user3515
    Sep 11, 2013 at 15:44
  • 1
    are you putting the code on visual editor? make sure you put it in text editor.
    – Sisir
    Sep 11, 2013 at 17:23
  • I'm putting it in the text editor
    – user3515
    Sep 11, 2013 at 17:42
  • You should be able to add a link in the spoiler with WP UI. Please edit your post, click on the "text" or "HTML" tab, and copy the code for the spoiler with the link that is giving you trouble. Include the [wpspoiler] and [/wpspoiler] tags and everything in between. Then edit your question here and paste that code so we can see it.
    – Ben Miller
    Sep 11, 2013 at 18:26

1 Answer 1

0

I was able to make your spoiler code work on my site. The <, >, and " characters in your spoiler code are encoded on your site, breaking the link. I think that either your theme or one of your plugins is encoding those characters.

To test your theme, temporarily switch to one of the default themes (such as Twenty Twelve) and see if that fixes the problem.

If not, deactivate your plugins and see if that fixes the problem. If it does, reactivate your plugins, one at a time, until the problem comes back.

10
  • I've got plenty of other links on my site, though!
    – user3515
    Sep 11, 2013 at 20:15
  • Is there any way to find the problem besides for testing out different themes? It's a live site, and I don't have a dev version set up to test with.
    – user3515
    Sep 11, 2013 at 20:16
  • It only takes a few minutes to switch your theme, load your page to test, then switch back. If you are worried about your site looking strange for a few minutes, then do it in the middle of the night to minimize the traffic on your site at the time of the test. Alternatively, set up a dev site and try to reproduce the problem there.
    – Ben Miller
    Sep 11, 2013 at 20:33
  • Is it easy to set up a dev site?
    – user3515
    Sep 11, 2013 at 20:42
  • Setting up a WordPress site for development purposes is just as easy as setting up a WordPress site for production purposes.
    – Ben Miller
    Sep 11, 2013 at 20:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.