I am using Wordpress 3.6, the latest version. When I access login page for admin URL like www.example.com/wp-admin and I enter the username and password, Wordpress redirects me to the same page.

But when I try to access using www.example.com/wp-login.php then it works perfectly.

When I try to login using wp-admin, I am redirected to www.example.com/wp-login.php?redirect_to=www.example.com/wp-admin%2F&reauth=1 strange URL.

I Googled it and found interesting thread on wordpress.org: http://wordpress.org/support/topic/wp-admin-suddenly-not-working, this thread seems inactive and old. I tried to apply all the suggestion but doesn't work

How to fix this issue? Is there any plugin for that or is there any error in some of the plugins?

Update I am using Subdomains and my site is accessed at www.subdomain.examplesite.com. And i am using windows hosting with IIS server.

  • Are you using subdomain? Sep 6 '13 at 9:29
  • Yes.. and edited the question too-!! Sep 6 '13 at 9:40
  • If you can login via wp-login.php .... have you tried to login via wp-login.php and disable all plugins to see if one of them is causing the problem? By the way, www.example.com/wp-login.php?redirect_to=www.example.com/wp-admin%2F&reauth=1 is not strange, it is totally normal, but it should be something like www.example.com/wp-login.php?redirect_to=http%3A%2F%2Fwww.example.com%2Fwp-admin%2F&reauth=1
    – cybmeta
    Sep 6 '13 at 10:19
  • I can login using wp-login.php but i am trying to login using wp-admin file. Sep 6 '13 at 10:53
  • I had a similar issue when trying to login to an URL without the www and redirect was to www version. This was because I had hard-coded a link with www and later configured the site to have no www in the site url in the dashboard settings. Also you can try clearing your cache and cookies.
    – TomC
    Oct 31 '13 at 12:58

In such cases, problem is probably with .htaccess file. Check if you use Multisite or which type (subdir vs subdomain)


Plugin conflicts cause most of these problems.

If you are able to log into using wp-login.php kindly log inside and check after disabling one by one each plugin and check your site wp-admin in different browser if disabling a particular plugin gives you access to wp-admin then that plugin is the cause of this.

It also happens in plesk cpanel sometimes due to permission problems.

Kindly check if you are able to add more media and or try adding one more plugin. If it gives error while uploading media that cannot add or permission problem then try to change folder permissions to 755 for wp-admin and you should be good.

  • sure.. i will try and let you know...:) Sep 6 '13 at 11:28

Changing Wordpress Salts solved this same problem, for me.


I had the same problem, I am using CloudFront as CDN and for me the solution was to forward these cookies in Cloudfront :


As you can see in this picture

cloudfront distribution behaviour settings



I found this wp-login.php solution

$user = wp_signon( ”, $secure_cookie ); old line
$user = wp_signon( array(), $secure_cookie ); fix

Credit to: bobferg



Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.