1

I am using a gallery to link to some sub categories. Some of the links within the category work exactly how they should. However there are a few that are adding strange characters on the end, I've re-done the permalinks but it still does it, you cannot see the extra characters in the link section of my gallery admin. Obviously by adding these characters, it is preventing the link from working and giving me the 404 message. It is vital to my website that my links work.

Can anybody think of a reason why they would not? I have tried disabling plugins and also looked for invisible characters.

"%20%E2%80%8E" variants of this are what is being added.

Really hoping someone can help me to solve this! Thanks.

  • Can you give us some examples of what a link should be, and what it's FULL output is. (and where you are putting said links within the gallery). – Eric Holmes Sep 4 '13 at 12:59
  • I am using a gallery called Pinwheel slider and at it appears at the bottom of wp media library. You can select to put the image into a slider and then input a slide link url. This is where i put the link and it does work on a few.This is what i am putting in as an example tbdowenholland.com/our-products/unpowered-gs ‎directly from the edit page and after clicking the image, this is what appears tbdowenholland.com/our-products/unpowered-gs/%20%E2%80%8E – Lauren Sep 4 '13 at 13:06
  • Okay. As I said, give some examples of your input vs. the output. It could be to due with special characters or spaces in your link (%20 is a space, for example) – Eric Holmes Sep 4 '13 at 13:07
  • I pressed enter by accident-I was putting the output in, its above in my original post, just in case you aren't notified of an edit. – Lauren Sep 4 '13 at 13:10
  • See my answer. Chances are some hidden breakpoint characters were on the HTML page where you copied those from (or even Word Doc). Go to the first link, and then copy it directly from the address bar. – Eric Holmes Sep 4 '13 at 13:11
0

Chances are you are copy+pasting the links in, correct? Depending where you are copying from, they could be filled with hidden space characters, like <wbr> in the actual HTML (if you copy from a website) which offers a break point. You need to paste these links into TextEdit, or Notepad, or Event the browser address bar to make sure no spaces are being stuck in there by mistake.

  • That is correct, I will re-do them and try it in notepad first. Thanks. – Lauren Sep 4 '13 at 13:13
  • Notepad should work great, but if it doesn't, use a browser. That's the best way to make sure the link works properly! – Eric Holmes Sep 4 '13 at 13:14
  • I just tried it, I am copying them from the permalink in the page edit and when i copied into notepad there was nothing untoward about the link, no extra characters/spaces etc. – Lauren Sep 4 '13 at 13:17
  • So hopefully now copying it from Notepad will fix the issue. – Eric Holmes Sep 4 '13 at 13:18
  • I'm not longer getting the error message, however rather than opening the link, it is going to an attachment page? – Lauren Sep 4 '13 at 13:22
1

The ugly URL trailing with %e2%80%8e is result of copy-paste content from Word, Excel or web page content. In this case copied content may include the special character which sometimes hidden ASCII space character. Just follow the below steps,

  1. Go to cPanel > phpMyAdmin
  2. Select the WP database
  3. Click on Search tab
  4. Enter value %e2%80%8e. Select the exact phrase with table wp_post. Please note that the table name might be vary; however usually ends with the word post.
  5. Browse the results. Now click on Edit link
  6. Navigate toward post_name and remove the ugly content.
  7. Finish

Hope this will help you. Based on the solution from DoubtSolver.

0

I just got this error. I was able to fix it easier than the replies you get here. Copy pasting in TextEdit was just doing the same thing, my URL still had these ugly characters:

https://girlknowstech.com/fr/%EF%BB%Bajouter-trello-google-calendar-ical

So what I did was that I edited the permalink of my post. I deleted everything, and re-typed it with the same thing I just deleted. My link now works as it should. I'm guessing there was an invisible character that was getting in the way! :)

0

I tried everything in here but nothing worked. At the end I switched browser from Edge to Chrome, retyped and it worked as it should've from the beginning.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.