2

For some reason, YoastSEO set my home page to the first blog post. So the home page canonical, title, and description are set to the values of the first blog post.

And when I tried to set the home page's title/description, I got this screen instead of the form fields to set the values of the title/description:

enter image description here

1

Check Settings > Reading. If you have a Posts/Front page page set, you'll need to add the meta title/description on those particular pages.

  • thank you. When I go to settings --> readings and try to set the front page as static page, the only option is give me is the about-us page. Is there a way to set the default page as the static default page from there? – Genadinik Sep 3 '13 at 15:33
  • You will have to create a page that you want to be the homepage, then assign it. – jmotes Sep 3 '13 at 15:36
  • thank you. But in theory, the home page is already created, right? It is my index.php page. How can I just set that as the home page? – Genadinik Sep 3 '13 at 15:36
  • In Settings > Reading, change Front Page displays to "Latest Posts". That'll cause the homepage to be generated from index.php. Also, you "should" then be able to set the meta title/desc on the Yoast page in your screenshot. – jmotes Sep 3 '13 at 15:38
  • 2
    "But in theory, the home page is already created, right? It is my index.php page." - Not true. The index.php template file is the default fallback template in the WordPress Template Hierarchy. WordPress Themes do not define pages; rather, Themes define template files that WordPress uses to render pages. Pages can only be created by the user. – Chip Bennett Sep 3 '13 at 16:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.