0

This is my first WP administration (I have inherited this from another developer), so I would appreciate it if you could treat me as a newbie.

I have a site with 40 or so pages and all the links on any page, image etc. are pointing at //www.mydomain.com, but I want them to point at //mydomain.com. The home page redirects clients correctly already (I believe this is a normal WP behaviour, as they think it is best practice and I am happy with that), but since the WP editor automatically creates links with the www subdomain, it's flicking back and forth between both as the user goes into the site.

I don't want to do a re-direct with the .htaccess file as that creates overhead (and this is a work-around, not the desired behaviour), but there are far too many to change manually, and I suspect that any new ones would also be created with the www prefix anyway.. So how do I change this behaviour as well as changing the existing links?

0

This could be as simple as going to Settings > General and ensuring that the values for WordPress Address (URL) and Site Address (URL) do not have 'www' in the textbox.

  • Thanks, but I'd already tried this (they're in a different place under multisite installs, BTW). – Astravagrant Sep 2 '13 at 10:04
  • Ok - I didn't see the multisite tag before and it wasn't mentioned in the question. I assume there's no redirect plugins installed? – TomC Sep 2 '13 at 10:28
  • No, no plugins doing anything like it (there are some, but they are not related, I've had a good look). – Astravagrant Sep 2 '13 at 13:21
  • A hack could be to check for www in the URL and then do a wp_redirect() to the correct URL but there must be something else causing this. I have to state that I have never used Multisite though. – TomC Sep 2 '13 at 16:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.