2

I'm trying to add a child theme to my wordpress installation. The theme the child should be based upon a theme called "nostalgia-landing" which is installed and works properly. I created a new folder called "nostalgia-custom" and added the the style.css with the following content:

/*
Theme Name: Nostalgia Custom
Description: Nostalgia Custom is a responsive WordPress landing page.
Author: QuanticaLabs and Christoph Halang
Author URI: http://themeforest.net/user/QuanticaLabs?ref=QuanticaLabs
License: GNU General Public License version 3.0
License URI: http://www.gnu.org/licenses/gpl-3.0.html
Version: 2.0.2
Template: nostalgia-landing
*/
@import url("../nostalgia-landing/style.css");

However, the theme selection in admin panel does not show my child theme and says "You only have one theme installed right now.". This is not true since there are the default themes. When I delete the child theme folder the default themes appear again in the selection.

Did I miss anything? Any ideas guys?

Regards,

Chris

12
  • Can you add a directory listing or screen grab of files and folders in wp-content/themes ?
    – jnthnclrk
    Commented Aug 22, 2013 at 14:33
  • Can't post images directly since I'm a newbie but here is a link Screenshot Commented Aug 22, 2013 at 14:35
  • Thanks, looks good, now we would need to see the contents of nostalgia-landing/style.css.
    – jnthnclrk
    Commented Aug 22, 2013 at 14:37
  • Since I bought the parent theme it is a rather long file :-/ I tried removing the import statement in my style.css with no effect, still no child or default theme visible. Commented Aug 22, 2013 at 14:40
  • Screen grab of Appearance page ( /wp-admin/themes.php )?
    – jnthnclrk
    Commented Aug 22, 2013 at 14:41

2 Answers 2

4

Problem solved: My child themes folder and the enclosed files had permission 750 instead of 644 set. Changed the permission and everything is working!

2
  • Good, glad you found your solution. Once you're able, accept your answer as the correct one, so that others with the same problem can benefit.
    – Pat J
    Commented Aug 24, 2013 at 21:37
  • Good tip to check permissions! However note that files should normally be 644: codex.wordpress.org/Hardening_WordPress#File_Permissions.
    – Mark Berry
    Commented Apr 4, 2017 at 1:44
3

Two things come to mind:

  1. Is nostalgia-landing a child theme of something (Nostalgia perhaps)? WordPress doesn't allow grandchild themes -- you can't have a child theme of a child theme. (Check the style.css file in the nostalgia-landing theme -- if there's a Template: line, then nostalgia-landing is a child theme. If that's the case, you'll need to make nostalgia-custom a child of the original theme.)

  2. Is this a WordPress Multisite installation? If it is, you need to Network Activate both your child theme and the parent theme. If you don't activate the parent theme, you can't use the child theme.

4
  • style.css is the only file required to create a child theme
    – JMau
    Commented Aug 22, 2013 at 16:29
  • Good point. Back to two.
    – Pat J
    Commented Aug 22, 2013 at 18:28
  • Hey, thanks for your thoughts on my issue, here's what I think: 1) No, there is no "template" line in nostalgia's style.css file. 2) I don't know exactly what an MultiSite installation is but my wordpress installation is the only one on the server and was recently installed. Commented Aug 23, 2013 at 12:50
  • This is Multisite. If you installed WordPress and didn't turn on Multisite, then that's not the issue. Your best bet might be to contact the theme developers that made your parent theme, and ask them about your problem.
    – Pat J
    Commented Aug 23, 2013 at 13:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.