0

I am using Persian Wordpress but I have a problem. when I want to publish a new post in Persian , I get all Persian letters alternated with question mark -"?" -. My wp-config.php file set the database charset to utf-8 .I installed Persian language to my Wordpress but it didn't fix my problem. you can see my full problem in chergheshab.ir . I also tried to change my collation from phpMyAdmin to utf8_general_ci but it didn't work . thanks a lot !

0

You should have all your databases utf8_general_ci if you're website uses other than just Latin characters. Can you have a look at your database tables? If you can then have a look at the wp_posts table and see if they are ???? or actual characters. Otherwise your posts are saved wrong in the DB which why they are appearing unreadable in your blog.

If they do not have utf8_general_ci unicoding try to:

  • Either create a new database with utf8_general_ci Unicode or try to convert your current DB. Documentation about converting a database. BACKUP if you need to!
  • Install a clean WordPress via FTP
  • Make sure your config.php has these settings (which are the default):

    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', ''); 
    
  • After installation make sure all your tables are utf8 general_ci (if you can access your database?)

  • Make sure your theme's index.php is saved with UTF-8 encoding.

Give it a try and let me know if this changed anything?

  • About last item "Make sure your theme's index.php is saved with UTF-8 encoding. ", how can I check it ? – reza Aug 23 '13 at 12:32
  • Open your index.php file with your code editor and choose File --> Save with encoding (depending on the editor) and then choose UTF-8. And then just upload the index.php file to your themes folder. – Laniakea Aug 23 '13 at 12:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.