1

Symptom: A custom post type assigned to a taxonomy does not appear in the admin table listing all posts with a specific term attached.

From my dashboard if I click on the taxonomy under the custom post type I get a list of terms. One term was showing 3 posts but when I clicked on the number 3 the resulting list showed only 2 posts. As a test I created a new custom post and assigned it to the same term. Now the list of terms shows that this term has 4 posts attached.However, clicking on the number 4 still gives me a list of 2 posts. I moved the posts to other terms and got the same result-namely 2 posts are still missing.

I don't know where to look analyze this problem. I suspect I'm either doing something very stupid (I've checked the obvious things like the custom post being published) or perhaps something in my database is corrupted.

I don't think there is any useful code I can provide. It seems to me that the problem is associated with the posts.I have a working version of this in a development site, which works perfectly. Now I attempting to recreate the same situation on the production site and this odd symptom has appeared.

I'd appreciate any suggestions on additional information I might provide here or any likely investigations I can make to find the source of the problem.

  • Any chance this taxonomy belongs to more than one post type? Or belongs to a post type that is no longer in use? – GhostToast Aug 21 '13 at 18:55
  • @GhostToast:Thx. No. According to the set up plugin for CPT & CT its 1 on 1. – dorich Aug 21 '13 at 19:07
  • What happens when you view a query for that taxonomy term? Out in the wild. Are those posts private? Belong to a different author? Etc. – GhostToast Aug 21 '13 at 19:10
  • 1.Viewing Query: I did this on the website page for the taxonomy. The DEBUG-WP-Query shows a count of 3, but the page only displays 2 posts. 2.Posts are not Private. 3. All posts have the same author. – dorich Aug 21 '13 at 22:37
  • Under "Settings -> Reading" how many posts per page are allowed? Can you manually assign a greater value (or -1) in your wp_query object? 'posts_per_page' => -1 – GhostToast Aug 22 '13 at 0:20
1

I resolved this by deleting the taxonomy and starting a new taxonomy with a slightly different name. Initial tests show the problem has been removed, although I can't say I understand what caused it.
Before deleting the taxonomy that caused the problem I created a new test taxonomy and showed that it worked correctly. I also did a backup of the site.

  • Sounds like it was cursed. Bummer. At least it's working now. Sometimes namespaces fight, such as page having same slug as a post-type. Things in trash hold onto their namespaces too. Not sure what happens to dead or dying taxonomies though, since those would seem more persistent. – GhostToast Aug 22 '13 at 19:25
  • Nevertheless your help was much appreciated. – dorich Aug 22 '13 at 23:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.