0

I'm trying to upload media using the media library. I uploaded a couple of images several months back, and the library worked fine, these images are still available as normal through the WP backend.

However, any new documents of any kind cannot be viewed due to a "failed to load" error. They're not accessable via embedded links (http://www.leghumped.com/wp-content/uploads/2013/08/lockscreen_shortcut-150x150.png) or attachment pages but I can see them when I click 'Edit->Edit Image' for a media item (the image source is '/wp-admin/admin-ajax.php?action=imgedit-preview&_ajax_nonce=46c2917e48&postid=650&rand=98186').

The permissions on my wp-uploads directory are 777 and I'm totally at a loss as to why this isn't working.

0

I'd moved the root of my site from /blog/ to / and not changed it in the general options. Everything seemed to work fine apart from the media library. Correcting the path solved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.