1

I recently uploaded a website to a new 123-reg server on a single WP installation (www.moseleycoachsales.co.uk). I had developed the site on my own hosted multisite environment (http://test.digitalgroupmedia.com/moseley/).

I had a nightmare uploading the website as the standard wordpress xml export/import facility that had always worked for me kept crashing crashing. In the end I managed to get the website live using this method (http://matteth.wordpress.com/2012/01/12/exporting-a-site-from-multisite-to-single-installation/)

The live website is now very sluggish and nowhere near the speed it was on my test environment. I don't know if this is down to the new server, or if something has occurred in the website move (perhaps database related) that has created the issue?

I'm not great with MySQl so don't really have the skill to diagnose this issue (if it even is the issue) and would really appreciate some help.

  • The initial hit alone takes over 3 seconds (according to gtmetrix.com) - chances are that you have some inefficient queries somewhere. You are also trying to load a non-existent bootstrap.css. – vancoder Aug 20 '13 at 17:14
  • Thanks for this. The inefficient query thing sounds like it's the case, but I don't understand how it can be a problem on a new server but not on the old? – James Stanza Middleditch Aug 20 '13 at 18:01
  • Also thanks for the bootsrap.css thing although I can't see where the non-existent link is? The website is built on bootsrap – James Stanza Middleditch Aug 20 '13 at 18:02
  • Useful info: codex.wordpress.org/WordPress_Optimization – Tara Aug 10 '14 at 15:05
1

Your site is very, very heavy at 4+ megs. Lighten it up; see http://gtmetrix.com/reports/www.moseleycoachsales.co.uk/eyz4qxQx

Fix the code errors, such as not specifying image dimensions, not correctly scaling your images, not optimizing your images, setting browser caching and expires headers, etc.

Your site speed has very little to do with one 404 for one style sheet. Use Firebug with Firefox, or use the developer tools in Chrome or Safari or IE to see what's loading on your site.

Your database may be oversize from revisions and your theme may be using more than the average number of queries. Use http://wordpress.org/plugins/debug-queries/ and http://wordpress.org/plugins/rvg-optimize-database/

And, every inexpensive host out there is slow. Check http://www.google.com/search?&q=123-reg+slow

  • Thank you for your help. I've set dimensions where I can, but a lot of images are generated dynamically and I can't set the dimensions. – James Stanza Middleditch Aug 23 '13 at 8:58
  • Despite some corrections to some obvious and best practice speed optimizing techniques (which I should've implemented in the 1st place granted), the website is still far slower than it should be. I know it lies in the database and query area somehow, but it's still beyond me. – James Stanza Middleditch Aug 23 '13 at 9:00
  • Every inexpensive host out there is slow; find a new host. – markratledge Aug 23 '13 at 15:38
  • The choice of host is out of my hands unfortunately – James Stanza Middleditch Aug 24 '13 at 12:10
0

In your head you have <link rel="stylesheet" href="css/bootstrap.css">. This is trying and failing to load bootstrap.css using a relative URL.

I would install the debug bar plugin and try to see what is going on, but if that's not in your comfort zone, first step should be to contact your host and ask if they can help.

0

opening your home page is consuming around 3,5 mb bandwidth, you must reduce it.

  1. Use WP Smush.it plugin for optimizing your image.
  2. Compress your .js and .css file via this site. http://cssminifier.com/
  3. I think you must remove css/bootstrap.css from your header file.because there is min version of this file.
  4. Use Cache plugin like w3 total cache or wp super cache.
  • thanks for this. I've followed these steps apart from the w3 total cache for the time being as it "broke" the website, no doubt because of incorrect settings on my part. I will look back at it though. – James Stanza Middleditch Aug 23 '13 at 8:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.