I've installed Total Cache plugin in my wordpress application and it suggested me to create a New Relic account. I've done it, but now the plugin ask me for an API key, and no idea of where to find it. I thought it would be the license key, but not. Anyone know where is it?

closed as off-topic by Mark Kaplun, Pieter Goosen, gmazzap, shea, Nicolai Aug 22 '14 at 9:33

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

  • 3
    What does W3 and New Relic support say? – Tom J Nowell Aug 18 '13 at 16:55
up vote 1 down vote accepted

This solved the problem:

  1. Select (account name) > Account settings > Integrations > Data sharing > API access.
  2. Click Enable API Access, and then put it on the required field in WP Total Cache general settings.

In addition to the answers above, ensure that your web server can make outbound connections to api.newrelic.com. If outbound connections are blocked by your server's firewall, then W3 Total Cache won't be able to verify your API key and report back to the New Relic client.

You need to sign in to your New Relic account and get it from your account settings.

https://newrelic.com/docs/subscriptions/license-key
  • It says me "The API key could not be verified. Please check it and try again." – Manolo Aug 18 '13 at 18:27
  • Is the New Relic PHP Agent installed on your server? Go to the New Relix info box on the W3 Total Cache dashboard. Does it say "PHP agent: disabled?" If it does then you need to install it or have your host install it for you. newrelic.com/docs/php/wordpress-users-and-new-relic – epilektric Aug 18 '13 at 22:58
  • PHP Agent is installed, but still doesn't work. – Manolo Aug 19 '13 at 9:02
  • I've finally succeed with API key, but I get this error: Notice: Undefined offset: 2 in /var/www/msalsas/wp-includes/class-http.php on line 386 Fatal error: Wrong parameters for Exception([string $exception [, long $code [, Exception $previous = NULL]]]) in /var/www/msalsas/wp-content/plugins/w3-total-cache/lib/NewRelic/NewRelicAPI.php on line 47 – Manolo Aug 19 '13 at 9:25
  • It sounds like you have a problem with a loop over an array: Undefined Offset 2. This might be something for the W3 Total Cache developer. – epilektric Aug 19 '13 at 15:55

Not the answer you're looking for? Browse other questions tagged or ask your own question.