1

How can I disable plupload completely from latest wordpress 3.6 and make browser upload default?

Thanks in advance.

  • 2
    This is a user setting. Once a user clicks the "browser uploader" link, WordPress remembers that setting for that user. There is probably a way to change the default setting for all new users to use the browser uploader, but I don't know how to do that. The setting is 'uploader'; if that user setting exists, then the user will get the browser uploader. See wp-admin/media-new.php, line 64. – Ben Miller Aug 16 '13 at 18:21
  • @BenMiller but it will just show and hide and will not disable plupload. – mha Aug 16 '13 at 19:34
1

This is how the plupload upoader is loaded on Media > Add New

do_action( 'pre-plupload-upload-ui' );

// all the html output for plupload's use

do_action( 'post-plupload-upload-ui' );

If it was this instead:

ob_start();

// all the html output for plupload's use

ob_end_clean();

Then no UI, no plupload:

add_action( 'pre-plupload-upload-ui', 'ob_start' );
add_action( 'post-plupload-upload-ui', 'ob_end_clean' );

However, the Add Media button on the post edit screen is a different ball game. Everything is pure js using backbone. I haven't got my hands dirty with those classes, yet. Someone else might be able to help with removing the Upload section from it and just have the Gallery. Or, you could

  1. Hide the default Add Media button using js or css.
  2. Hook into do_action( 'media_buttons', $editor_id ); to create your own Add Media button.
  3. Load your own UI.

But I'm not sure if that is a great idea.

0

To disable the Flash uploader add the following filter to functions.php

function disable_flash_uploader() {
    return $flash = false;
}
add_filter( 'flash_uploader', 'disable_flash_uploader', 7 ); 
  • @jhon I have tried the code and it did not work. As from wordpress3.3 it uses plupload. So only disable flash uploader will not disable it. – mha Aug 16 '13 at 18:55
  • @mha Sorry I had a typo that I just corrected on the top line. I test this with WP 3.6 and the 2012 Theme – John Aug 16 '13 at 22:16
  • 1
    @jhon not working :( – mha Aug 18 '13 at 4:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.