0

As the title says, do_action( 'init' ) in wp-settings.php breaks my website. All plugins and themes have been disabled.

Basically if I comment out line 308 which is simply do_action( 'init' ); then the site works fine, but if I enable that line, I see just a white page, no HTML in the source at all. I've disabled all plugins and themes. How do I continue troubleshooting from here?

UPDATE: The problem is due to a bad cron job, the output of my list of cronjobs is here:

FUNCTION                        ARGUMENTS               SHEDULE TIME (H)
wp_scheduled_auto_draft_delete  array ( )               Once Daily  24
wp_scheduled_delete             array ( )               Once Daily  24
publish_future_post             array ( 0 => 43169, )   not-set
wp_version_check                array ( )               Twice Daily 12
wp_update_plugins               array ( )               Twice Daily 12
wp_update_themes                array ( )               Twice Daily 12
do_pings                        array ( )               not-set
sm_build_cron                   array ( )               not-set

The function sm_build_cron is from the plugin google-sitemap-generator and the function referenced it:
Action:

//WP Cron hook
add_action('sm_build_cron', array('GoogleSitemapGeneratorLoader', 'CallBuildSitemap'),1,0);

Function:

function CallBuildSitemap() {  
    if(GoogleSitemapGeneratorLoader::LoadPlugin()) {  
        $gs = &GoogleSitemapGenerator::GetInstance();  
        $gs->BuildSitemap();
    }
}
  • 1
    do you have debugging enabled? – Milo Aug 14 '13 at 16:40
  • 2
    It's not the init action that's breaking your site; rather, it's your Theme or a Plugin that is outputting code that produces a fatal error on init. Enable debugging, and report the fatal error that is generated. – Chip Bennett Aug 14 '13 at 16:58
  • I enabled it, and nothing changed. No output, just a blank page, nothing in the source of the page either. – Branndon Aug 14 '13 at 17:00
  • 2
    The blank white page is due to some error in wp-cron. I've added this line to my wp-config.php define('DISABLE_WP_CRON', 'true'); and everything works fine now. Now I have to find an alternative cron manager. – Branndon Aug 14 '13 at 17:40
  • 1
    Updated @kaiser – Branndon Aug 14 '13 at 19:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.