1

Since the upgrade of WP to v.3.6 I've started getting regularly logged out.

This is NOT after a couple of days (without 'REMEMBER ME' checked) or a couple of weeks, and NOT when I've closed the browser then opened a new one later. This is when a browser tab has been open on the Dashboard (or other Admin page) but idle ... to be honest, not exactly sure how long for, but minutes and maybe hours, not days or weeks.

Wouldn't be too bad except that the system then redirects to a 'popup' window sized for the standard WP login form, except that I use a plugin ('Theme My Login') and have customised the login page that it uses. Result is that the popup window shows a portion of this page only ... and unfortunately not a part that includes the 'LOGIN' button. It also doesn't let me scroll left | right only up | down, so I can't actually get at the button. It's therefore necessary to close the popup, navigate back to my 'normal' sign in screen, and log on there.

It isn't earth shattering, or a show stopper, but it is annoying.

Can anyone tell me how / where I can change the auto-logout time / behaviour or if not, at least if / where I can redirect the popup so that instead of the WP form it steers me back to my 'normal' login page?

(Of course, it's entirely possible that this shouldn't be happening, and I've erred somewhere and caused it myself! In which case ... any ideas what I might have done?)

2

In WordPress 3.6 they added the "heartbeat" to the admin area and one of the features is this authentication check. You can disable this admin auth popup by adding the following to your functions.php file...

// Remove admin login popup
remove_action('admin_enqueue_scripts', 'wp_auth_check_load');
  • Wow, an answer ... as they say: 'Better late than never'. Bizarrely the problem seems to have mainly gone away. I say 'bizarrely' because I didn't consciously do anything to achieve this. However, it does recur every now and then so I've added the script to functions.php. The good news is that it accepted it. The bad news is that I don't know how to deliberately try to force an automatic sign-out, so I won't know that it's working. If it DOES work, I won't be prompted to think about the issue again - so thanks in advance! ;-) – Kevin4fm May 7 '14 at 3:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.