1

I've installed a domain-based Multisite on my server, and everything works including each of the subdomains. Here I should explain that I imported a Database that was on my Local Mac, and then changed the details in the database for each site. However, I now can't access wp-admin for the main domain or any of the subdomains, Chrome just tells me there is a Redirect Loop (http://cl.ly/Qg7K). Let me just clarify that I can't access wp-admin at all, i.e not even the login page.

I'm reasonably confident with Wordpress, Databases and servers, so I can most likely get any data back for you and carry things out to test, try to fix etc.

Thanks for any help!

EDIT: People asked for my .htaccess code. It was copied from my localhost installation but I was using a Virtual Host so there were no paths involved. I'm no expert with .htaccess though so something could be wrong.

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# uploaded files
RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

# add a trailing slash to /wp-admin
RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
RewriteRule ^(.*\.php)$ $1 [L]
RewriteRule . index.php [L]
  • Check your .htaccess. – kaiser Aug 6 '13 at 14:49
1

Chances are something doesn't line up in the database. The values in wp_options->site_url should the an exact match for the wp_blogs->domain + path values.

I made a post here on the tables needed to change to transfer a multisite. Double-check these values.

For subdomain multisites, your domains should be site1.domain.com and path should be /, where your site_url should be site1.domain.com/.

Also, check your wp_sitemeta->siteurl value, and make sure it makes your blog1's values.

  • None of your advice seemed to make any difference :/ sorry :( – Tom Oakley Aug 6 '13 at 14:49
  • Is your wordpress directory in the root of the server? If not, make sure your subdriectory is in the path portion of data in wp_blogs, not in the domain. – Eric Holmes Aug 6 '13 at 14:53
  • Yeah it is in the root (public_html). – Tom Oakley Aug 6 '13 at 14:56
  • Does navigating the sites inner pages work fine? Event on subdomains? It could be an .htaccess issue. It's Rewrite Base should be /, so it could be messed up if copied from localhost (which would have the folder it was stored in MAMP on) – Eric Holmes Aug 6 '13 at 15:24
  • I've added my .htaccess code in the main question. It was copied from localhost but I was using a Virtual Host (e.g maindomain.dev, subdomain.maindomain.dev etc) so there were no paths. – Tom Oakley Aug 6 '13 at 15:54
0

It's not really a solution, but to fix this I reinstalled Wordpress (as Eric Holmes said in our discussion) and re-enabled Multisite, so the wp-admin section works. I then hooked up it to my previous database, installed my themes and everything now works as expected, as far as I can see. :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.