When uploading an image to a post/page, the media library doesn't display any images (when there are some), and then 'fails' when you try and upload (although the image is actually uploaded).

I've checked file permissions (everything is owned by the server which has full and appropriate access; i've event tried setting it to 777), and deactivated all plugins and tried switching themes. None of which helped. this happens even with 2013 active.

The strange thing is that I can see the ajax request in the inspector, and it's retrieving all the information about the images ( from the wp-admin/admin-ajax.php request), in the data object. So wordpress should know it's there....

I just upgraded to 3.6 to see if it fixed the problem (which started in 3.5.2), but nothing has changed.

I'm using nginx, not apache;

Does anyone have any idea about what could be failing here and/or what could be causing this? (even somewhere to start looking would b super helpful). I've tested with a fresh DB and it's still happening.

1 Answer 1


In case any poor soul runs in to something similar, I've found the problem:

define('WP_DEBUG', false);

Running debug mode (as I do on all dev sites), was throwing a warning, but it was being returned in the 'admin-ajax.php' which was preventing the images from showing/uploading and returning the appropriate values etc.

I cannot believe the answer to debugging was to stop debugging. Jesus.

I'm away to file a bug report now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.