-1

My hosting at wp-engine wont allow me to upload this file by git because of a syntax error. Can anybody see what the error is?

<?php
$aryWPMUConfig = get_site_option('wpmu-piwik_global-settings',false);
if (is_plugin_active_for_network('wp-piwik/wp-piwik.php') && $aryWPMUConfig) {
foreach ($aryWPMUConfig as $key => $value) {
    self::$settings->setGlobalOption($key, $value);
}
delete_site_option('wpmu-piwik_global-settings');
self::$settings->setGlobalOption('auto_site_config', true);
} else {
self::$settings->setGlobalOption('auto_site_config', false);
}
self::$settings->setGlobalOption('dashboard_seo' = false);
self::$settings->setGlobalOption('stats_seo', false);
self::$settings->setGlobalOption('track_404', self::$settings->getOption('track_404'));
self::$settings->setGlobalOption('track_compress', false);
self::$settings->setGlobalOption('track_post', false);

This is update/90001.php from wp-piwik

closed as off-topic by fuxia Aug 1 '13 at 14:30

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

1

Your setGlobalOption() call here is different from the rest:

self::$settings->setGlobalOption('dashboard_seo' = false);
self::$settings->setGlobalOption('stats_seo', false);

I think your = should be , instead.

  • Thanks, that solved it. ive been puzzling over this for about 3 hours. – Sofia Rose Aug 1 '13 at 14:31
  • WP_DEBUG is your best friend, sometimes. Even if you can set yourself up a WordPress installation on localhost, and test things before you push them to wpengine. – Pat J Aug 1 '13 at 14:35
  • I tried that but the plugin installed and ran with no comment even though it contained that error. – Sofia Rose Aug 1 '13 at 14:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.