I have done the following:

-- Installer WordPress and enabled MU on the main site (main.com).

-- Changed wp-config.php of the MU to the following:

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# add a trailing slash to /wp-admin
RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^(wp-(content|admin|includes).*)  [L]
RewriteRule ^(.*\.php)$  [L]
RewriteRule . index.php [L]

-- Changed the second domain (second.com)'s nameservers to be the same as the main domain. Then I added the second domain as an addon domain in cPanel. For web root of the second domain I choosed htdocs/main.com (the directory where WP MU is installed).

I didn't just park it, because the WordPress MU is not installed in the root directory of the cPanel account and I am using shared hosting.

-- Installed the WP domain mapping plugin: http://wordpress.org/plugins/wordpress-mu-domain-mapping/

-- Went to the Network admin in the main site and under Settings->Domain mapping, I've entered main.com in the "Server CNAME domain:" fields.

-- Under Settings->Domains I've added the domain second.com as the main domain for the WP install with ID 2.

-- Under Sites->All Sites I've edited site with ID 2 and changed its domain to be http://second.com, keeping the checkbox "Update siteurl and home as well." checked.

Now when I visit second.com in my browser I simply get redirected to the main WP site - main.com, whereas it should show me the WordPress child site instead.


1 Answer 1


Maybe the same issue i had a few days ago. Under each site's setting, you should switch the domain to second.com. (Each site's has a domain mapping settings too, where the default is main.com/second, and if you added the other domain to site on the network administration, it should appear the option to choose the second.com)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.