I've been Googling this for a while:

I was on 2.8 when this bug occurred, so first thing I did was finally upgrade to 3.1. It didn't fix anything.

Next thing I did was disable all the "Update Services". Didn't fix.

Then I tried disabling all plugins. Didn't fix.

Occasionally it WILL post/publish/update, but only part of the post, leading me to believe all the data is not being submitted (?).

Another interesting thing to note that has happened - around the same time this started happening, my admin password stopped working and I was unable to login. Email recovery wasn't working either. So I had to manually change my password using MySQL.

Any suggestions?

Another thing to note is that this "bug" appeared all of a sudden. I had not made any changes to WordPress in the interval since my last successful post, and when I started noticing the bug.


This issue has been corrected. There was an iptables rule which had been previously added due to a domain getting attacked on the server which wasnt removed and was matching a part of the post you were making. I have removed the rule and the post is not functioning correctly

  • 1
    Does this happen just with WordPress, or are there any other PHP/MySQL applications on the same server that are having trouble?
    – jdp
    Mar 1 '11 at 17:37
  • Other PHP/MySQL apps seem to be working. Another thing I noticed is that the value for user_pass in my wp_users table keeps getting corrupted ...
    – Zack Burt
    Mar 3 '11 at 19:22
  • Are there errors in the mysql log or apache errorlog? Mar 3 '11 at 20:30
  • Can you make a few things more specific, please?...If you say sometimes only part of the post is submitted...what parts are these? Is it only part of the content or is the content saved but not meta data or the other way around.....? What do you mean by that it 'hangs'? Did you try exporting your blog and re-importing it? Do you have a large number of posts or is it moderate?
    – wyrfel
    Mar 4 '11 at 13:55
  • (1) I have 70 posts & a handful of drafts. (2) I just tried exporting posts, reinstalling WP, copied/pasted my themes&plugins and the bug (hangs while trying to update long post) STILL occurs. Augh, how frustrating! By hangs, I mean "I hit update, and then it just spins until the browser gives me a timeout error." Part of the content is saved -- I think the meta data is saved, but the post content is truncated. For example, I might get cut off mid-sentence.
    – Zack Burt
    Mar 4 '11 at 20:26

Initially this sounds like a hosting problem and not a WordPress issue. Where are you hosted? Shared? Dedicated? php version? mysql version?

Run through a typical wp hack protocol and check for base64 code in wp-config.php, any theme files and akismet plugin files... also any other php files. Database hacks are sometimes hard to find too but mostly located in the wp_options table..

Read into the hack fixing at Dre's site: http://blog.sucuri.net/2010/07/understanding-and-cleaning-the-pharma-hack-on-wordpress.html


Turn off ALL plugins

Check in settings > writing in the "update services" section... for now just make sure only rpc.pingomatic one is in there remove the rest.

Check in settings > Discussion and for now uncheck "Attempt to notify any blogs linked to from the article"...

Try to post...

what happened?

--- hopefully one of those fixed it. I'd also try the above but try a fresh install of the twenty-ten theme and change your site to that theme after fresh install and try posting again.. could be something in your theme...


  • Very cool checklist. I ran through all of these and ultimately had no luck. I have actually isolated the problem -- wordpress barfs on this text: ***Have them call up a number with a prerecorded voice mail. "Do not fax your resume to (xxx) xxx-xxxxx [competitor's fax machine]. Do not email your resume to x@x.com [competitor's email address]. Do not call by phone at (XXX) xxx-xxxx [competitor's phone number]. Instead, please send your two-page letter not by postal mail, DHL or UPS, but by FedEx only, to 123 Main Street, Anytown, Anystate, Zip Code [your nonpostal mailbox service]."****
    – Zack Burt
    Mar 4 '11 at 23:31
  • yeah it's probably some base64 code in your file system... search your files. Apr 1 '11 at 23:20

In addition to plugins, don't forget that themes can change how WordPress behaves. Try switching to the TwentyTen theme temporarily. Does the problem go away? If so, then your theme's functions.php file would be a place to start looking, see if it's doing something odd with post creation hooks.


My first question would be how is the front end of the site responding? If it's running ok and you are only experiencing problems on the backend I'd be concerned with my database or something to do with the update or maybe your site has been compromised by hackers.

If the entire site is slowed down (front-end and back-end) I'd start looking hard at my hosting provider. I experienced a similar issue and it turns out the hosting provider had issues on their end. After much complaining we were able to get things fixed but as we grew we eventually moved to a VPS provider.

I hope this helps.

  • Front end is responding just fine. :/
    – Zack Burt
    Mar 4 '11 at 20:26

First thing I think about when I hear "password" in the issue is possibility of a hack. There are plenty of legit things that can go wrong, but this is always worth checking for with scrutiny.

Second, there are not many details to go by... But it seems to me that basic distinction between when you do and do not experience the issue is fact of posting large stuff in form. This is something that can be easily caused by poorly or overly agressively configured hosting settings, such as mod_security. At my hosting I had to open ticket and ask to whitelist several WP core files because of similar (but milder) issues with posting.

Not the answer you're looking for? Browse other questions tagged or ask your own question.