4

How to have pagination of RSS2 feed ?

My current RSS link is similar to :

http://www.example.com/?feed=rss2

I tried:

http://www.example.com/?feed=rss2&page=2

But WordPress still returns me with same set of result, given that I set 10 posts per page in

Dashboard > Settings > Reading > Syndication feeds show the most recent

(of course I have more than 10 posts)

  • Yyyy... And why are you trying to add pagination to rss? I don't think that RSS readers will use this... – Krzysiek Dróżdż Jul 29 '13 at 9:31
  • 1
    but my mobile App will use this – Raptor Jul 29 '13 at 9:32
11

You want to use paged not page in the request and it should work.

You can find more information about WordPress pagination paged parameter here.

2

You have to set the page load from WP-Admin > Settings > Reading:

In Syndication feeds show the most recent choose how many items will be in each page of the feed.

And now your feed is pagination-ready. Browse it with:
http://www.example.com/?feed=rss2&paged=1

Default Permalink:
Syntax: http://domain/?feed=rss2&paged=#

For any other permalink, other than Default, a question of mine is still waiting unanswered. There you will find more syntax about RSS feed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.