15

I have been looking at whether it is possible to remove blog/ from the post & category URLs on the root node in a multisite setup.

I have found the multisite sites settings and removed the blog/ part of the URL and saved. Despite it changing all of the links correctly when I click them I just end up with a 404.

If I go to the node dashboard itself and resave I get the blog/ URL rewritten into the changed multisite permalinks. Sometimes creating something like this blog/news/postname

Has anyone managed to do this in the past? I am wondering if it is possible without hacking the core or getting a bit more hands on with some .htaccess rules.

19
  1. At blog site set Settings -> Permalinks -> Common Setting -> Default (Must select default only and don't touch any thing, If you need to change category base, tag base set at Network Admin only)

  2. At Network Admin -> Sites -> (root site) Permalink Sturcture -> /%category%/%post_id%

That it will remove /blog slug

  • This is a good approach although it doesn't work if BuddyPress is installed due to BuddyPress requiring non-default permalinks. Any idea how to get around this? – henrywright Sep 5 '13 at 11:21
9

screenshot of Network Admin settings

Step 1: Go to /wp-admin/network/site-info.php?id=1

Network Admin -> Sites -> Edit -> check Permalink Structure.

Edit as per your requirement.

Step 2: Go to normal site level

Settings -> Permalinks

Select or add appropriate permalink.

  • I could not find the Network Admin -> Sites -> Edit -> check Permalink Structure through navigation so I used the URL you gave in your step 1 and that worked! Thank you. Had been spending a lot of time on this. – Aditya Bajaj Jul 21 at 14:05
2

These are the steps.

  1. Change the permalink setting in network admin to /%postname%/

  2. Going to permalinks settings of the site will fix the 404

  3. Result: Working WordPress Multisite without /blog/ slug.

Source with step-by-step screenshots.

Permalinks

1

Add a new page with news as slug. Go to Settings > Reading and choose your news-page as static page for blog posts.

Then go to Settings > Permalink and customize your structure like /%category%/%postname%/ and your blog post slugs should all be /news/post/ by now.

0

At root site, Click on permalink and choose "plain"

At network level Site > click edit under the root site > Click on settings > Do a crtrl + F to find "Permalink Structure" > add %post_id% in the field.

0

For anyone looking for the answer as off Dec 2018 do the following.

Go to the network admin, select the root website and click edit.

Goto the settings tab. There is a massive list of options, look for the Permalink Structure field. remove /blog from the Permalink and hit save. I also went back to the root blogs admin area and clicked on the save button on the permalinks section to clear the cache.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.