I've got Wordpress running on WAMP. For some reason, when I check for updates to the core and to my plugins, it tells me that everything is up to date, even though I know that I am one version behind on the core and on three plugins. Why am I not picking up these updates?

I checked file permissions, and they're all good. Tried disabling all plugins. No difference. Also, I tried to re-install my current version of the Wordpress core, and got the following output;

Downloading update from http://wordpress.org/wordpress-3.5.1-no-content.zip…
Download failed.
Installation Failed

I get no other feedback. Any ideas what is going on? An almost identical version on the live server is showing the updates just fine.

Update: I haven't gotten any answer that solve this problem. Useful information would be what domains or subdomains Wordpress needs to connect to in order to check for and download updates. That way I could debug the connection to those domains.

Update: I still haven't gotten any solutions. I suspect it has something to do with Apache not being able to connect to outside servers, but I have no idea how to solve that.

  • 1
    Check the permissions on wp-content. I would almost guarantee that this is a file/folder owner/permissions issue.
    – s_ha_dum
    Commented Jul 24, 2013 at 20:43
  • Like I said, I already checked the file permissions and they're all good. Commented Jul 25, 2013 at 16:08
  • Did you check the owner/group? That is an often forgotten component when file permissions are involved. See: wordpress.stackexchange.com/a/96454/21376
    – s_ha_dum
    Commented Jul 25, 2013 at 16:12
  • 1
    I'm on Windows, so I'm not really sure how to follow those instructions. Can anyone give me advice on how to check the file permissions on Windows? Commented Aug 13, 2013 at 13:38
  • 1
    Sounds to me more like a firewall issue or the like. If you have any firewall software installed, check to make sure that WAMP is allowed to access the network. Commented Aug 13, 2013 at 14:14

7 Answers 7


I use XAMPP myself, but WAMP isn't much different.

I'll bet you have not enabled the curl module. WordPress can use other methods (streams and fsockopen) as a fallback, but these may be disabled by default as well in a stock install. Curl is preferred and easy to enable.

  1. Close WAMP
  2. Go your the \bin\php\version directory in WAMP
  3. Edit the php.ini, and uncomment the line that reads extension=php_curl.dll
  4. Do the same thing in \bin\Apache\version\bin\
  5. Save and restart WAMP.

Edit: WAMP may also have an easier way to do this through the graphical interface. Look for "PHP extensions" and "php_curl" and make sure it is enabled.

  • Interesting. I would suspect that this isn't the issue, because the updates used to work, and then just suddenly stopped. But out of curiousity I checked this out. The php.ini in my Apache directory already had curl enabled, but the one in the PHP directory wasn't, so I enabled it, but I get an error on starting WAMP; "Unable to load dynamic library... php_curl.dll ...side-by-side configuration is incorrect..." Commented Aug 14, 2013 at 12:55
  • @JosiahSprague I am guessing you are missing the .dll file then. Make sure it's in PHP's extensions directory (different for Windows and Unix I think).
    – Dzhuneyt
    Commented Aug 15, 2013 at 10:04
  • The .dll is there. I also checked the file permissions on the .dll, and they're fine. Commented Aug 15, 2013 at 13:20
  • Given that kind of problem, I'd remove WAMP, and install XAMPP instead. XAMPP works just swell.
    – Otto
    Commented Aug 15, 2013 at 14:02
  • I might try that, but given that I've been using WAMP for three years with no problems, and that I'm not even sure that this Wordpress thing has anything to do with WAMP, I'd like to explore other soultions first. Commented Aug 19, 2013 at 13:05
  1. First Open /wp-config.php

Now the first thing you need to do is to open the wp-config.php file from your WordPress root folder, the file is located at wordpress/wp-config.php

  1. Insert FS_METHOD

Paste the following code to your wp-config.php file, preferably just below every other line of code.


And Save it, It will definitely work. It worked for m successfully.

  • What exactly does this do? Commented May 25, 2019 at 23:32

"Download failed." comes from failing the download_url()

can you try running this inside one of your files:

$url = "http://wordpress.org/wordpress-3.5.1-no-content.zip";
require_once(ABSPATH . "wp-admin/includes/file.php");
$file = download_url($url);
echo "<pre>";
echo "</pre>";

That should give you one of the folowing error messages:

WP_Error('http_no_url', __('Invalid URL Provided.'));
WP_Error('http_no_file', __('Could not create Temporary file.'));
WP_Error( 'http_404', trim( wp_remote_retrieve_response_message( $response ) ) );
WP_Error('http_request_failed', __('A valid URL was not provided.'));
WP_Error( 'http_request_failed', __( 'User has blocked requests through HTTP.' ) );
WP_Error( 'http_request_failed', __( 'Destination directory for file streaming does not exist or is not writable.' ) );
  • I think you're onto something, but I tried this and got; Fatal error: Call to undefined function download_url() in C:\wamp\www\doulos\wp-content\themes\doulos\front-page.php on line 9 Commented Aug 13, 2013 at 18:22
  • sorry, the function is only automaticly included in wp-admin, add the row require_once(ABSPATH . "wp-admin/includes/file.php"); to include it.
    – Puggan Se
    Commented Aug 13, 2013 at 20:08

I've noticed that weird things happen when running WAMP without admin rights. If none of the above works, try launching WAMP Server as an adminstrator and see if that helps (even if your user account has admin rights). If it's not running as admin, that might be preventing WordPress from seeing there is an available update.

To run WAMP as Administrator, click on your start menu, type wamp, right click "Start wampServer" then click on "Run as administrator".

Screenshot of running WAMP as administrator

  • 1
    Great idea! Unfortunately, I tried it and it didn't work. Commented Aug 14, 2013 at 12:47
  • That's a bummer. Have you ever tried XAMPP? I finally gave up on WAMP after all my issues. Perhaps switching to a different program will help you get your WP installation working. I know it doesn't solve the problem on WAMP, but it could help eliminate your frustrations.
    – Ian
    Commented Aug 14, 2013 at 15:04

You could modify the wp-config.php.

And add below code :

define('FS_METHOD', 'direct');

On my side, it's resolved.

  • What does this do? Commented May 25, 2019 at 23:32

I have similar issues and first and foremost I would say use XAMPP it's awesome for any PHP development on windows as WAMP gave up on me many times earlier and xampp has worked always & even has a portable edition (using it for past 4-5 years now).

Now, for your problem you have tried other suggestions so i wont say those like(permission,admin privileges etc. ) it but i think that can be a issue of slow internet connection as that's how it is on my side .

try to see if it is even downloading anything by using some network monitoring tool (task manager > network tab can give you a rough idea if any other internet app is not running ) , and if you see data transfer and that too for sufficient duration to download 4-5 MB's then it's Ok, other wise the problem is in WAMP or File system permissions etc.

I also had a hunch that your host file might have been changed by someone , so check if wordpress.org is not there in your host file & is not pointing to or something other than actual wordpress.org servers .

I hope that helps you !


I remember I encountered a similar situation a while back what solved the problem in that instance was to specified a temp directory on my wp-config file see if this works for you. just add the following line to your wp-config.php file


  • Thanks for the suggestion. I tried this and it didn't work. Commented Aug 22, 2013 at 17:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.