5

I'm running Wordpress (v3.5.2) in network mode.

Any of the sites which try to access /wp-admin produce a browser error saying there is a redirect loop. A redirect checker tool says the page returns a 302 temporary redirect to the same URL.

I have uploaded a default .htaccess file and the same thing happens.

In cPanel, I have checked Domains > Redirects, and there is no such redirect listed.

I have renamed /plugins to /plugins2, and the issue remains.

In the wp_options table, the site_URL is set to www.example.com, which is correct. This matches the DOMAIN_CURRENT_SITE parameter in wp-config.

Any ideas?

3
  • I'm having this issue too, on a shared host. Other wordpress installations on this host do not exhibit this behavior. Aug 1, 2013 at 17:19
  • Hi Jeff. I uploaded fresh copies of /wp-admin & /wp-includes which resolved the problem.
    – Steve
    Aug 3, 2013 at 2:58
  • I did that, without effect. However my hosting provider has noticed a segfault that may indicate bad RAM on the server. It's being replaced tonight. Fingers crossed. Aug 3, 2013 at 3:19

5 Answers 5

0

I ended up uploading fresh copies of /wp-admin & /wp-includes, as well as the wp files in the root / directory, which resolved the problem.

1
  • In my case, it turned out to be an infected theme. Aug 4, 2013 at 4:29
0

I had this problem as well, it turned out to be a hosting issue with the permissions of some of my files being chmod 0664 and the host not like group to be writable. I changed the files to 0644 and everything worked. There is never a clear solution to this problem, but that may help for people looking for other solutions.

0

There is a plugin called "change-wp-admin-login" - check that or move it out of the plugins folder temporarily

0

For me this happened because I set the sitename/hostname to https:// after enabling SSL in Cloudflare. Apparently this is not supported.

The solution was to revert the sitename/hostname to http:// and use the "Flexible SSL for CloudFlare" addon. The manual is here, but for me it just immediately worked after installation.


If you can't revert your sitename/hostname because of the wp-admin redirect issue, you can revert it manually from the command line.

Use

mysql --user=myDbUserName --password myDbName

to enter your DB (it will prompt you for the password), then to fix, run

UPDATE wp_options SET option_value='http://www.yourwebsitehere.com' WHERE option_name IN ('home', 'siteurl')
1
  • You say that "apparently this is not supported", do you some kind of reference or source for this, please?
    – JDandChips
    May 18, 2023 at 12:34
0

I also had this issue. It turned out it was due to using the "Flexible" Cloudflare TLS setting, which causes CF to make requests over HTTP and add their own self-signed HTTPS certificate.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.