I have been using WordPress multisite for several years without a problem. At some point in the last few days one of my many multisite domains is stuck in a redirection loop.

The domain is http://www.drandrewhall.com and as of this writing is stuck in a redirection loop. This worked fine until a couple days ago.

I have removed it from the domain mapping plugin and added it back in. I can remove the www domain and add in just the drandrewhall.com as the primary and it works fine.

I've looked at the database tables and everything seems to work. I've changed the theme, removed all the plugins, made sure everything is up to date, but the problem remains.

All the other multisite sites are working correctly and this one was until 3 days ago.

  • 1
    Could you be more precise about the question you ask? Give more details about it please. – JMau Jul 14 '13 at 14:04

It's likely down to an nginx configuration if your server runs nginx.

For example, an nginx default config could contain:-

if ($host ~* ^www.domain.co.uk) {
    rewrite ^(.*)$ https://domain.co.uk$1 permanent;
}

This would result in your server trying to set a 301 redirect from www to non www but then when www is defined in Wordpress, the server tries to redirect back to non www causing an infinite redirect loop.

We've recently experienced this with a Wordpress website and exhausted every possible route on the Wordpress side as it sounds that you have done subsequently coming across the nginx config at domain level on the server.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.