16

I have been trying to find a solution. but I can't..

my links are all domain.com/index.php/post_name/

I really want to remove /index.php

I have searched and found some... saying I need to add these.. but it's not working ..

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

I am using 3.5.2 wp.

Please let me know if you know anything about it.

  • are you using apache and is mod_rewrite enabled? this is probably a question for your particular host. – Milo Jul 9 '13 at 6:52
  • i have no idea. i am just using a web hosting service. – pulla Jul 9 '13 at 7:28
  • should I disable to remove "index.php"? – pulla Jul 9 '13 at 7:29
  • @pulla You need to find out more about your web hosting service and what sort of configuration it runs on. – Otto Jul 9 '13 at 7:58
18

Go to your WP-ADMIN-->Settings-->Permalink and use the permalink structure change there, if it generate any .htaccess file copy the content and update your .htaccess file.

Or Check if your hosting mod_rewrite is enable by creating a file phpinfo.php with content,

<?php phpinfo();?>

Upload this file and browse via Browser. So you know which modules are enabled. You need mod_rewrite enable to remove index.php from URL.

More details Check this link

  • Thanks for your answer. I have tried but I don't know it's not really working. it could be the hosting problem. I removed all and installed. nothing has be changed. – pulla Aug 11 '13 at 6:10
  • 1
    Facing the same issue. Removing index.php in under wordpress permalink give error "The requested URL /wordpress/test-page/ was not found on this server." – Muhammad Azeem Jun 24 '16 at 9:46
3

Had exactly same issue. But in my case mod_rewrite was not installed at all for apache. I just installed it with

sudo a2enmod rewrite

and then changed my Permalink Settings. Worked like a charm.

Hope it helps.

protected by Community Nov 13 '16 at 1:22

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.