1

i'm completely confused, want to use my own template file for a custom post type and of course i read all about this here or in the Codex (http://codex.wordpress.org/Post_Types#Custom_Post_Type_Templates )

Also i found users with the same problem ( https://stackoverflow.com/questions/14461285/what-would-make-a-custom-post-type-template-not-show-up ), and of course i already have updated the permalink page (change the setting > save > change setting to original back > save !). Nothing has worked out so far :( .

What did i done ?

First i register my custom post type as usual with that code:

register_post_type( 'series', array(
      'supports'                => array('title', 'editor'),
      'menu_position'           => 20,
      'show_ui'                 => true,
      'show_in_nav_menus'       => false,
      'show_in_menu'            => true,
      'public'                  => true,
      'register_meta_box_cb'    => array($this, 'addMetaBoxes'),
      'public_queryable'        => true,
      'has_archive'             => true
    )
);

After the registration i expected to have access to my custom template file, if i create the single-series.php template file inside my theme root directory.

But ... boohhh.

All the time my 404.php is called instead of my desired custom template file... what (the hell) goes wrong ??? Do i forget something important ? ...argghh ! Please help.

Thanks in advance!

  • Try saving permalink settings. – Vinod Dalvi Jul 3 '13 at 13:03
  • Did you try with changing permalink structure? Can you send me your site link? – Vinod Dalvi Jul 3 '13 at 13:06
  • i've just tried, change the permalink structure to something other and back - no success ! :( What do you mean with 'site link' ??? My custom post type should be accessible by mysite.com/series/name-of-the-series ... – Alex Jul 3 '13 at 13:10
  • He means the URL to the site - unless you are working locally. Try "disabling" your permalink settings (first option) and try viewing the post. See if it comes up when it goes to mysite.com/?p=123 – Eric Holmes Jul 3 '13 at 13:13
  • i'm working locally ... still :/ – Alex Jul 3 '13 at 13:14
0

Now that it's working without permalinks enabled, try resetting your permalinks back to the way you want them. That full reset should work.

Edit: Are you be doing anything funky with the rewrite argument?

  • Thank you very much Eric, this full reset worked out - i don't changed the rewrite-argument. What did i done: 1. I've changed the permalink structure back to standard 2. Save 3. Call a custom post page with the preview function - custom post template file was shown. 4. Turn back the permalink settings to your custom settings – Alex Jul 3 '13 at 13:35
  • Glad to hear it! What probably happened is you set your permalinks before setting up the post type. I believe that permalink settings need to be changed for it to take into account a new post type (unlike how normally you just need to visit the Permalinks page to update). – Eric Holmes Jul 3 '13 at 13:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.