I've been developing a wordpress website (with a custom theme) for a month. Today I wanted to upload an image to a page and I got a message saying there was an error and I should try again later.

I tried to upload the image directly to the library and I got the following error:

1096 Notice: ob_end_flush(): failed to delete buffer zlib output compression. in (...)/wp-includes/functions.php on line 2707

I deactivated all plugins, that didn't work. I tried changing the theme to twenty twelve, that didn't work. Is there anything I can do to fix this issue, or at least understand what this is all about?

  • 2
    Couple more things to check: Does your wp-uploads folder have the right permissions? And do you still have free space on your server? Commented Jul 2, 2013 at 13:44
  • The wp-uploads folder have 777 permissions, and I still have free space on the server.
    – Cthulhu
    Commented Jul 2, 2013 at 14:55
  • For security you shouldn't have higher than 755, but I'm afraid I don't have the answer then. Commented Jul 2, 2013 at 15:01
  • I just changed to 777 to test if that was the issue. Thank you for your help anyway.
    – Cthulhu
    Commented Jul 2, 2013 at 15:34

1 Answer 1


Apparently this is a new Wordpress bug (I'm using version 3.5.2). Just set wp_debug to false and it works perfectly again. Hopefully they'll fix this soon.

define('WP_DEBUG', false);

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.