PHP 5.5 has been released recently. In the same time has been announced that PHP 5.3.x branch won't be supported anymore after 5.3.27 will be released.
However WordPress requires PHP version 5.2.4 and higher. I understand that WordPress guaranties that it will work on a hosting with PHP 5.4 or 5.5 installed. But in the same time it means that I can't use PHP 5.3, 5.4 or 5.5 features in my WP development as it could cause an issue on a hosting with PHP 5.2.x installed. If I use PHP 5.3 and higher features in my plugins/themes, then they are won't be 100% compatible with WordPress.
Does anybody knows if WordPress is going to change it's requirements?