0

I'm trying to embed this code into a post:

<script src="http://www.stokerposter.com/swfobject.js"></script>
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="422" height="750">
    <param name="movie" value="http://www.stokerposter.com/Stoker_Poster_04.swf" />
    <!--[if !IE]>-->
    <object type="application/x-shockwave-flash" data="http://www.stokerposter.com/Stoker_Poster_04.swf" width="422" height="750">
    <!--<![endif]-->
      <img src="http://www.stokerposter.com/Stoker_Poster.jpg" alt="" />
    <!--[if !IE]>-->
    </object>
    <!--<![endif]-->
</object>

But the result in the preview always falls back on the image, and the comment tags <!-- are visible for some reason. Is there any way to embed this without a plugin?

Thanks

2
  • 1
    by "no plugins" - you mean no PHP code?
    – birgire
    Jun 20, 2013 at 18:16
  • I mean no plugins for embedding HTML.
    – ddario
    Jun 20, 2013 at 20:59

2 Answers 2

1

Sounds like you are using the Visual side of the editor.

enter image description here

You need to use the Text side.

enter image description here

Get it?

Update:

Preview won't show embedded objects. Publish it privately if you absolutely must see it before anyone else, and need to see embedded bits like <object> tags.

Update #2:

Preview will show many embedded objects now as of WP 4.0. And many embeds can occur from merely a URL (tweets, youtube, for example).

2
  • Nope, I'm suing the Text side of course.
    – ddario
    Jun 20, 2013 at 20:58
  • i updated the answer
    – GhostToast
    Jun 20, 2013 at 21:00
0

I think WP is making assumptions about what you're inputting into the editor. Try disabling its automatic paragraph tagging.

http://davidwalsh.name/disable-autop

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.