1

I am using the plugin: Advanced Custom Fields. For several more images, I used it to add images using the image input field.

Now, when I edit a post, I can't edit/add new image into the image field using the plugin. Using Firebug, it shows a js error:

Uncaught ReferenceError: tb_show is not defined

But the same fields work, when I add a new image using those fields.

5
  • Did you try to add wp_enqueue_script( 'thickbox' ) to your functions.php? Jun 20, 2013 at 10:23
  • tried. But it's not working. :( Posted the same question now to the WP.org support thread. Jun 23, 2013 at 6:58
  • @MayeenulIslam Please clean up your accounts.
    – fuxia
    Jun 23, 2013 at 9:42
  • disable other plugins and switch to default theme, check if the issue still exists.
    – Milo
    Jun 23, 2013 at 17:53
  • @toscho, Nishi is a colleague of mine. Not my account. :) And we both are in the same project with the same problem. :( Jun 24, 2013 at 4:15

1 Answer 1

5

Did you also add wp_enqueue_script('media-upload') in functions.php ?

I tried this and it's working:

function load_admin_things() {
    wp_enqueue_script('media-upload');
    wp_enqueue_script('thickbox');
    wp_enqueue_style('thickbox');
}

add_action( 'admin_enqueue_scripts', 'load_admin_things' );

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.