0

When i navigate to /wp-admin/ i am redirected to wp-login.php with the wp-admin URL in the redirect_to parameter. Like this:

http://www.domain.com/wp-admin
... goes to ...
http://www.domain.com/wp-login.php?redirect_to=http%3A%2F%2Fwww.domain.com%2Fwp-admin%2F&reauth=1

If i just navigate to /wp-login.php/ i get an endless redirect loop.

Things i've tried:

  • Removing the .htaccess file in the root
  • Renaming the /wp-content/plugins/ folder (to check if any plugins are messing things up)
  • Renaming all cookie keys in wp-config.php
  • Changing permissions of the wp-login.php file to 755

Those are solutions i've found through other forums. I haven't had any success with either of them.

Basically what happened is a few months ago i was editing the site theme, and everything was working then. I haven't logged in until today, and now that i tried logging in i was met by this error.

Any other ideas?

  • have you logged in? if you have, then have you checked your server's disk space? – Prasad Ajinkya May 30 '13 at 13:52
  • 1
    You don't mention having swapped to the default theme, like leaving only twentytwelve inside the /themes/ folder. – brasofilo May 30 '13 at 13:54
  • I just tried renaming the theme folder, it made no difference for the login behaviour. It just made the frontend completely blank, which was expected. Any other ideas? – qwerty May 31 '13 at 6:39
2

Try reinstalling WordPress by replacing all the core files. Make sure you don't touch the /wp-content/ folder (and/or back it up). Perhaps something goofy has happened to one of the core files.

Edit:

Try checking permissions on wp-login.php - should be 644.

  • Nope, that didn't help. :( For the record, here is the url to the website: goo.gl/xa73c – qwerty May 31 '13 at 16:06
  • Try refreshing permalinks? Settings -> Permalinks. Then try again. – GhostToast May 31 '13 at 16:09
  • updated answer. see if that helps? – GhostToast May 31 '13 at 16:18
  • I tried refreshing permalinks between every change, that didn't help. But i did solve it, and it was indeed related to the wp-login.php file, although i am not sure what exactly was wrong with it. What happened is i cloned the entire site down locally and tried to login, then i got a 404 for the wp-login.php file (i didn't get that before). So i checked and the file wasn't there. Then i checked the server, and the file was there. So i tried downloading it, but that didn't work (didn't have permissions!??). ... – qwerty Jun 1 '13 at 17:43
  • ... Weird. So i just renamed the file, then uploaded a fresh copy of it, and now it works. The thing is, i've never touched the wp-login.php file before, so i don't know what initially changed the permissions of it. I did however change it to 755 (which turns out was wrong, but whatever) myself while trying to fix it. – qwerty Jun 1 '13 at 17:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.