1

I'm facing a really weird problem with my wordpress/server.

Sometimes when I add media (images) to a new post, and then try to submit this post, instead of my website I got the information in browser:

connection rejected by server

I contacted my hosting provider to solve this problem and they claim that my wordpress is generating too many simultaneous connections to server and that's why my IP is being blocked (usually for about 48 hours). For everyone else the site is working perfectly fine.

Is it possible that adding images/submitting the post is generating more than 18 connections to server (that's the limit that my hosting provider has on its servers)?

And if yes, how to solve this problem?

I'm using wordpress always updated to the newest version.

  • Is this PHP 5.3? core.trac.wordpress.org/ticket/23968 – fuxia May 26 '13 at 12:58
  • Nope. 5.2. I can set also php 5.4 or php dev – Gacek May 26 '13 at 13:13
  • For the record, I run a number of sites on PHP 5.3 and don't have this issue. It would help if you could post the logs showing exactly what those connects are. Also, are you running any plugins? And if so have you tried disabling them? – s_ha_dum May 26 '13 at 14:13
  • 1
    Do you mean web hosting provider? ISP (internet servvice provider) is typically company that provides you with access to Internet. If they give you hosting with weird restrictions - I'd look to change to real hosting. :) – Rarst May 26 '13 at 20:07
  • 1
    Try looking up setting for number of connections to server in your browser. Or, you know, nagging your hosting into removing stupid restriction. I am thinkings this probably can't really be handled on WordPress level. – Rarst May 27 '13 at 13:32
1

I contacted my hosting provider to solve this problem and they claim that my wordpress is generating too many simultaneous connections to server...

The only times I've seen hosts put limits on the number of MySQL connections is when the host is free or very cheap or incompetent.

Is it free hosting? It's really easiest to spend a little money and get a good host.

See Recommended WordPress Web Hosting

  • Nope, I use 1&1 hosting called "Unlimited" (hic!) 1and1.com – Gacek May 27 '13 at 16:45
  • 1
    1&1 is a problematic host. Their "Unlimited" package is far too cheap to be quality. Search the wordpress.org forums for opinions on them. And do a reverse DNS lookup on your IP to see how many other sites are on your server; that's another reason for an overloaded server. – markratledge May 27 '13 at 17:55
  • 1
    Reverse DNS lookup shows me only one domain - serverklienta.pl (client server). Which is probably top-level domain for many, many clients... – Gacek May 27 '13 at 20:30
0

Many web hosting companies "throttle" accounts based on the number of simultaneous I/O connections & amount of CPU resources consumed. Your shared hosting should support around 10-20 simultaneous active users under this configuration for WordPress. Sounds like you were only using the site in development & triggered the account throttling, which may point to either problems in the WP install or overactive targeting by the web host. Check the error logs for the web site & consider another shared hosting plan with better resources.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.