0

I have a couple of sites on a shared hosting server.

The sites load just fine, and everything appears to work, including local links. The only thing that isn't working is that the entire wp-admin directory is throwing a "too many redirects" error message.

Here is what my redirects look like to handle the domain (this is the only non-standard part of this install):

<configuration>
    <system.webServer>
        <rewrite>
          <rules>
            <rule name="Site 2 Redirect" stopProcessing="true">
                <match url="^(.*)" />
                <conditions>
                    <add input="{HTTP_HOST}" pattern="^blog\.site2\.com$" />
                </conditions>
                <action type="Rewrite" url="/site2/" />
            </rule>
          </rules>
        </rewrite>
    </system.webServer>
</configuration>

I did see other posts claiming that the admin folder required 705 permissions, which I have set to no avail.

Any help would be greatly appreciated.

1

I suggest you to enable WP_DEBUG 'ON' to find out the error. You can enable WordPress debug editing wp-config.php file by adding define( 'WP_DEBUG', true );

Check the following document for better understanding https://codex.wordpress.org/Debugging_in_WordPress

0

I do not really know where your problem comes from but I know a trick to fix this issue in some case :

ErrorDocument 401 default

This code goes in main .htaccess at the very beginning.

Hope this will do the job.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.