0

I need to import a whole bunch of non-WordPress posts in to Wordpress. I would hope it would be pretty straight forward as there are no pictures or anything; it's basically just a bunch of text. I'm testing out the WordPress Importer plugin but I'm not having much luck, even just using dummy data.

To remove all the variables, here's what I did... I exported all of my WordPress posts to the xml wxr file, removed all but one post with only text, replaced the post data with dummy text, resaved it and imported it.

After I click 'Upload Files and Import', the body of the import WordPress turns white and nothing happens. I find that the file has been imported as a txt file with the body of the xml document and is located under Media.

Can anyone offer any suggestions as to why this is happening.

Update - Debug info: Class 'DOMDocument' not found in /var/www/html/wp-content/plugins/wordpress-importer/parsers.php on line 61

  • Please add debugging information – s_ha_dum May 20 '13 at 16:41
  • Did you follow the link? Do you have debugging enabled? – s_ha_dum May 20 '13 at 16:49
  • Debugging info: Class 'DOMDocument' not found in /var/www/html/wp-content/plugins/wordpress-importer/parsers.php on line 61 – ItsGeorge May 20 '13 at 16:49
  • s_ha_dum, yeah sorry. I thought I had it on already. I've added it now. – ItsGeorge May 20 '13 at 17:16
2

DomDocument is a PHP extension. It is either not installed or is disabled. You will need to install that module and/or enable it.

You will need server level access to correct it. That is, you will need to be able to configure PHP. How you do that depends on what kind of server you have, so I am not sure what else to say at this point. Perhaps if you were to edit your question to include server details...

  • s_ha_dum, Thanks, that's probably all I needed. Hopefully it won't be an issue. I'll let you know what happens. – ItsGeorge May 20 '13 at 17:51
  • That was it. Enabled Dom and everything is working properly. – ItsGeorge May 21 '13 at 19:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.