Bounty Ended with 100 reputation awarded by fugitive
2 updated the answer
source | link

If you have access to remote MySQL, this MIGHT help you. I've done this a while ago when i had another issue with my hosting provider.

Take a full backup of your WordPress files, but not your database. Copy them to your localhost. Now, instead of using a local database, in your wp-config.php file, set your database to the remote database of your online website (obviously make a backup first).

define('DB_HOST', 'YOUR REMOTE DATABASE');

Now, force the local installation to use the localhost as Site URL and Site Address, by defining these in wp-config.php :

define('WP_SITEURL', 'http://localhost/');

define( 'WP_HOME', 'http://localhost/' );

Now, you can disable mod_sec on your local Apache web server and update your posts.

PS: I did not try this with mod_sec, and i do not guarantee this to work for you. I don't even know if this is officially confirmed, but since i did this myself and worked, i considered sharing it with you (since it was too long to post as a comment). I don't even know if it's secure or not.

However, be warned about hardcoded URLs and uploads, because these will cause an issue if you are trying to upload files while on localhost. But modifying the content itself, shouldn't cause a problem.

PS 2 Please be gentle with your downvotes. Although it may look sillymore like a science-fiction project, but it personally worked for me, so i can't accept people telling me this will never work.

If you have access to remote MySQL, this MIGHT help you. I've done this a while ago when i had another issue with my hosting provider.

Take a full backup of your WordPress files, but not your database. Copy them to your localhost. Now, instead of using a local database, in your wp-config.php file, set your database to the remote database of your online website (obviously make a backup first).

define('DB_HOST', 'YOUR REMOTE DATABASE');

Now, force the local installation to use the localhost as Site URL and Site Address, by defining these in wp-config.php :

define('WP_SITEURL', 'http://localhost/');

define( 'WP_HOME', 'http://localhost/' );

Now, you can disable mod_sec on your local Apache web server and update your posts.

PS: I did not try this with mod_sec, and i do not guarantee this to work for you. I don't even know if this is officially confirmed, but since i did this myself and worked, i considered sharing it with you (since it was too long to post as a comment). I don't even know if it's secure or not.

PS 2 Please be gentle with your downvotes. Although it may look silly but it personally worked for me.

If you have access to remote MySQL, this MIGHT help you. I've done this a while ago when i had another issue with my hosting provider.

Take a full backup of your WordPress files, but not your database. Copy them to your localhost. Now, instead of using a local database, in your wp-config.php file, set your database to the remote database of your online website (obviously make a backup first).

define('DB_HOST', 'YOUR REMOTE DATABASE');

Now, force the local installation to use the localhost as Site URL and Site Address, by defining these in wp-config.php :

define('WP_SITEURL', 'http://localhost/');

define( 'WP_HOME', 'http://localhost/' );

Now, you can disable mod_sec on your local Apache web server and update your posts.

PS: I did not try this with mod_sec, and i do not guarantee this to work for you. I don't even know if this is officially confirmed, but since i did this myself and worked, i considered sharing it with you (since it was too long to post as a comment). I don't even know if it's secure or not.

However, be warned about hardcoded URLs and uploads, because these will cause an issue if you are trying to upload files while on localhost. But modifying the content itself, shouldn't cause a problem.

PS 2 Please be gentle with your downvotes. Although it may look more like a science-fiction project, but it personally worked for me, so i can't accept people telling me this will never work.

1
source | link

If you have access to remote MySQL, this MIGHT help you. I've done this a while ago when i had another issue with my hosting provider.

Take a full backup of your WordPress files, but not your database. Copy them to your localhost. Now, instead of using a local database, in your wp-config.php file, set your database to the remote database of your online website (obviously make a backup first).

define('DB_HOST', 'YOUR REMOTE DATABASE');

Now, force the local installation to use the localhost as Site URL and Site Address, by defining these in wp-config.php :

define('WP_SITEURL', 'http://localhost/');

define( 'WP_HOME', 'http://localhost/' );

Now, you can disable mod_sec on your local Apache web server and update your posts.

PS: I did not try this with mod_sec, and i do not guarantee this to work for you. I don't even know if this is officially confirmed, but since i did this myself and worked, i considered sharing it with you (since it was too long to post as a comment). I don't even know if it's secure or not.

PS 2 Please be gentle with your downvotes. Although it may look silly but it personally worked for me.